Unable to update server to latest version

Hello wonderful internet volunteers! I’m trying to update my server, but I can’t seem to get the update to run correctly.

My YunoHost server

Hardware: Intel NUC, Celeron N2820 2.13Ghz CPU, 8GB RAM, 120GB SSD
YunoHost version: 11.2.8.2
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
All of the above, but I prefer the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I’m attempting to update my server from yunohost 11.2.8.2 to the latest version, 11.2.11.3

I went to the System Update section of the webadmin, let it load, then clicked the “Upgrade all packages” button for the system (not applications).

The page begins to load, displaying what packages it’s getting (I assume), but quickly switches to a “Trying to communicate with server” dialog which then quickly resolves into a “you can login now” message.

After logging in again, nothing has been updated.

I also tried running these commands directly from the command line

yunohost tools update
yunohost tools upgrade system

but had no luck with that either.

Is there another way to update the server to the latest version?

Can you share the output of this command ?

Here’s the output of the yunohost tools upgrade system command. Sorry for the phone pic; I don’t have a good way of copying text from the server’s CLI.

the command | yunopaste

and share the generated URL here on the forum. :innocent:

1 Like

It looks like the apt cache ain’t up to date (even though you ran yunohost tools update)

So let’s look at : yunohost tools update

J’ai l’impression qu’il s’agit du même problème que Php (sury.org) bloque les mises à jour system

1 Like

Here’s the output of that command:

https://paste.yunohost.org/raw/xoxicawoza

Perhaps just sudo apt update? Then see if it magically fixes itself.

2 Likes

You must be some kind of wizard because that seemed to have worked.
I had to run sudo apt upgrade --fix-missing after running sudo apt update, but I’m on the latest version now.

Thanks!

1 Like