Unable to update APT due to strange error

My YunoHost server

Hardware: VPS bought online / Old laptop or computer / Raspberry Pi (specify version, 0 to 4) at home / Internet Cube with VPN / Other ARM board / …
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no / yes
If yes, please explain:

Description of my issue

So I tried to update my Yunohost system for the first time today, but to my confusion and frustration, it errors out and gives me this message:

I have no idea why it is giving me this message and I am unsure how to fix it. All the “problematic” lines seem to be all my APT sources, so that narrows down nothing for me. I’m really in a rut right now and would like some help or advice on what is going on.

Supposedly there should be other error messages in the history in the webadmin…

We can also check what’s the actual message running sudo apt update from the CLI

After running the CLI, it did give me this error:

Updating from such a repository can’t be done securely, and is therefore disabled by default

The repository in question is packages.sury.org, which my server could not find any public keys to verify it.

In that case this is a recurring issue these day because Sury’s key expired

You can update it with:

wget -nv -O - "https://packages.sury.org/php/apt.gpg" | sudo apt-key add -

I tried that all and all that was spit out at me was

ERROR: Could not open HSTS store at ‘/root/.wget-hsts’. HSTS will be disabled.

And then nothing was downloaded. Now I’m even more befuddled and am just wondering if I’m on a bad luck spree…

Well, after rebooting the system, it seems that now the updates go through without any friction. Thank you so much for the advice!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.