Unable to run Yunohost after Installation due to Main Domain value


I have my running normal website say www.mywebsite.com hosted in a shared hosting service provider long back which is running under ipaddress1.
Now i deployed the Yunohost solution in a new cloud server having ipaddress as ipaddress2. During post installation steps, when it asked for “Main Domain” i gave the value as the main website domain (as above).
The installation process went well. but when i tried to open through the ipaddress2 url in browser, it opened the admin panel asking for the password. But when i clicked on “User Interface” button, then it is trying to open the url as “https://mywebsite.com/yunohost/sso/?r=12345” and thus the page throws an error.
How can i point any subdomain to the existing installation to resolve this issue? The reason is, if i use a subdomain as “Main domain” value in post installation steps, then internally it takes everything as subdomain including the ldap, etc which i would like to avoid.
Is there any way to handle the situation. Kindly suggest.

Hi, Aleks suggested to create a new domain and then make it as default one and that worked and resolved the issue.

Thanks much.

Thanks and Regards,

1 Like