Unable to renew letsencrypt certificat


Hello / Bonjour
I’m unable to renew certificat with letsencrypt

My YunoHost server

Hardware: ersonnal server
YunoHost version:
repo: stable
version: 11.1.15
repo: stable
version: 11.1.8
repo: stable
version: 11.1.4
repo: stable
version: 11.1.4
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I m unable to renew my letsencrypt certificat
My network look like this
WAN - Brideged freebox - Turris Omnia - LAN
Seem to be a timeout problem / firewall

Timeout during connect (likely firewall problem)', ‘status’: 400}

exemple here : https://paste.yunohost.org/raw/oxurupupog
but port fordwarding it’s ok
if I try with telnet

telnet music.mydomain2.tld 80
Escape character is '^]'.
GET /.well-know/
<head><title>302 Found</title></head>
<center><h1>302 Found</h1></center>
Connection closed by foreign host.

I tryin to switch to a self signed certificate and reintall letsencrypt but no luck, same error
On other server/domain I use acme.sh script and it’s work great maybe I can give a a try to use it with yunohost
If someone have any idea ?

Have a nice day

Solved partially
i disabled ipv6 … and able to renew music.domain2.tld

EDIT: Other one not pass directly with renew
I try to switch cloud.domain2.tld to self signed I install letsencrypt cert
Same error (ipv6 still disable)
telnet work on this host too

I did a diagnostic and I notice all port seem not reacheable but I tryin to make a nmap outside my network and all port is open
I already see person who have issue with Turris omnia and port forwarding

Not shown: 992 closed ports
25/tcp   open  smtp
80/tcp   open  http
443/tcp  open  https
587/tcp  open  submission
993/tcp  open  imaps
5222/tcp open  xmpp-client
5269/tcp open  xmpp-server
5280/tcp open  xmpp-bosh

Here we go I’ll check with a tcpdump what happen exactly

After Turris OS upgrade to 6.3.1 and reboot it’s worked again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.