Unable to receive email for secondary user

,

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: 4.1.7.4 (stable)
I have access to my server : Through SSH, through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
App: Rainloop

Description of my issue

I can’t get email to work with my secondary user.

Details

My server has two users and two domains:

• user_one
• user_two

• domain_one.ltd
• domain_two.ltd

And each user has an email address:

• user_one@domain_one.ltd
• user_two@domain_two.ltd

And this is what happens:
√ when user_one uses domain_one.ltd to send out email, email is delivered.
√ when user_one uses domain_one.ltd to receive email, email is received.
√ when user_two uses domain_one.ltd to send out email, email is delivered.
! when user_two uses domain_one.ltd to receive email, email is not received.

I have been using YunoHost for a few years for easy things and I am now started using email.
I’m sure it’s something very silly from my side and it can be fixed easily, but I cannot find it.

Maybe I should add that domain_one.ltd and domain_two.ltd are from different registrars but I don’t think that’s the problem [correct me if I’m wrong].

Hope you can show me the right path.
Thanks

It was a DNS issue.

For some reason, one of the DNS records wasn’t propagating while all the others did. I don’t know why.

I have moved from Dreamhost to Cloudflare and now everything works as expected.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.