Unable to re-install "SEND" application - hangs on web ui at building

So first and foremost, I want to thank everyone who works on the Yunhost project. Trying to tinker with Linux has been a covid19 project of mine and it’s great learning new things.

I tried searching for a solution and wasn’t able to find much. If I missed anything, please send a link and will try again to figure this out on my own.

Hardware: Oracle VPS / VM.Standard.E2.1.Micro
YunoHost version: (Stable)
**I have access to my server : Yes, full root via ssh
**Are you in a special context or did you perform some particular tweaking on your YunoHost instance ?: no
**If your request is related to an app, specify its name and version: send 3.4.23~ynh1

Description of my issue

I set up a tiny instance for a personal website. I had Linkstack setup, Send, and PrivBin.

For some reason, Send service stopped working. I tried to resolve this on my own by restarting and then re-installing.

But now when trying to re-install, it starts the process… but then nothing happens. I tried to leave this idle for 3+ hours, but it never finishes.

Here is a screenshot of where “Send” gets stuck:

Interesting enough, the LinkStack site and PrivBin also stops:

I wish I had logs to provide. Let me know if I can post log files or anything to help figure out a solution.

I know your time is valuable, so I would really appreciate any help on this. Thank you!!

Hmmm from what I can see in our automatic test, building the app requires a good~ish 1GB of RAM which may be too much for your server ? That kind of depends on the total amount of RAM + available amount of RAM with other stuff being already installed


Thank you for the response.

My instance does have 1 GB RAM - and it seemed to build it fine on the last install…

it is slow to build and takes lots of RAM.

some things you could try:

  • before installing, shut down some services to have max ram available:
    sudo yunohost service status #to see what you have running
    sudo yunohost service stop SERVICE
  • install it with the terminal: sudo yunohost app install send
  • let it run, if it fails, give us the error message here
1 Like

Thank you to all the responses; I am thankful for everyone’s time.

Here is me attempting to install the app via ssh:

And here is the error that was generated:

Any help would be appreciated.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.