Unable to login to Pleroma - error is always invalid credentials + error

My YunoHost server

Hardware: VPS 4Gb, plenty of storage, 2 cores
YunoHost version:
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I installed Pleroma onto my main domain (e.g. mydomain.com), but everytime I try to login, I get an error “Invalid credentials” and an error in the log:

2020/06/06 21:46:29 [error] 14018#14018: *642 connect() failed (111: Connection refused) while connecting to upstream, client: , server: mydomain.com, request: “GET /api/v1/timelines/public?only_media=false&limit=20&with_muted=true HTTP/2.0”, upstream: “http://[::1]:8095/api/v1/timelines/public?only_media=false&limit=20&with_muted=true”, host: “mydomain.com”, referrer: “https://mydomain.com/main/all

I tried logging in with the username, the email address and admin. Any suggestions appreciated.


I don’t use anymore pleroma and I am not an expert but I read that pleroma needs a domain for its own, different from the main domain.

Thanks. I have the same problem with Pixelfed installed to photos.mydomain.com.

In fact, the only apps so far that have worked for me are Mattermost and NextCloud. I get 401 errors in Mastodon. I’m not having a good day. :slight_smile:

@YurkshireLad : I don’t see any similar issue for Pleroma, but I would try to login using a browser in private mode without being logged in the SSO. (At least that should be the workaround for Mastodon, c.f. the issue the repo bugtracker …)

Alternatlively, look at the README of Pleroma_ynh to learn how to reset the password

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.