Unable to Install on VirtualBox - Framebuffer not available, disabling graphical frontend

My YunoHost server

Hardware: VirtualBox 7.0.4 on an Lenovo ThinkCentre, running i5-4570, Intel HD 4600
YunoHost version: 11.0.9, 64-bit
I have access to my server : No
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I am trying to install Yunohost on VirtualBox, but I got stuck very early in the process
Repro steps:

  1. Power on the VM
  2. On the Yunohost installation screen, select Graphical install
  3. The screen scrolls with some message, then the following message flashes “Framebuffer not available: disabling graphical frontend”

See https://i.imgur.com/sT6N55a.gif

I tried a different graphics controller, but I got the same error:

The “Invalid settings detected” has to do with the fact that I had remote display enabled without the Virtualbox Extension pack installed. I am still stuck with remote display disabled.

I have no recent experience using Virtualbox, I suspect the issue is not Yunohost-related.

Is this the step where Debian is being installed? I think installations of Yunohost on Virtualbox are a minority; you may have more success getting help on a Virtualbox-forum.

Yunohost runs on plain Debian. Once you got Debian installed, you can install Yunohost on top.

virtualbox being makes issues with yunohost 10 or 9, i don’t remember, but i had the same exact problem as you described before and we did try to understand what’s the cause of it for several hours in the chat room, but version 11 to best i know don’t do these issues anymore, but why don’t you use vmware instead?
vmware are much lighter, and easier to use.

there is a way to install yunohost on top of debian thats for sure are going to help in that case, see the bottom of that thread:

there is a link with instructions how to do it,
so basically you can download debian and then install yunohost, debian will not produce such problem on virtualbox,

aside that make sure you’re using the latest virtualbox version with all the extensions installed, though i strongly advise you to use vmware due to many troubles you’re going to get in the future with virtualbox such as bloated disk,

hosting a server on a virtual machine is not the same as to host that on a physical one, there are many things need to come in concern, virtualbox is good for development and testing when you want to host a server that’s not the best choice though its free, its have many limitations and problems, but you can try,

in any case you decided to go farther with the virtualbox save this command for future use cause you will need it:
sudo dd if=/dev/zero of=wipefile bs=1024x1024; sudo rm wipefile

that will shrink your container (virtual hard disk) when it will be bloated after a while.

by the way the usual button “shrink disk” will not do anything but will say success when in reality your disk will stay at the same size" that’s why you need this command,

thee are other issues with networking and port mapping on virtualbox which are not always possible to solve but give it a shot.

also in your screenshot the “Extended Features: Enable 3D Acceleration” is unchecked, you need to check it for graphical use. though i am in doubt that’s the cause. but it should be checked anyway,

best regards

Thanks wbk for pointing out that it would be Debian issue rather than Yunohost, and izkis for suggesting VMWare instead.

I am getting the same error with VMWare, so I’ll probably just install an older version of Yunohost for this test.

the same error with vmware?!
i am using vmware to host all of my servers never got any problem,

have you tried to check the 3D Acceleration in both virtualbox and vmware?
what error you get with vmware? and what vmware version is it?

please install debian not yunohost, just download debian, install it, and then install yunohost with commands i think you misunderstood me about installing yunohost on top of debian,

that should solve it.

Hi izakis. Thanks for your suggestion on installing Debian first. I didn’t try that, but instead, I tried to install yunohost-bullseye-11.0.9-amd64-stable.iso directly.

Last night, I got the same error in VMware - the frame buffer error.

The following steps are all performed on VMware workstation player 17.

Today, I deleted the VM and tried installing yunohost-bullseye-11.0.9-amd64-stable.iso again. I checked 3D acceleration in VMware player and that actually caused VMware to crash, so I unchecked it, and I was able to proceed with the installation.

I don’t know what’s the root cause of this, but I am glad that it’s working now.

1 Like

glad it helps
if you’re going to host yunohost regularly on vmware and you face any issues don’t hesitate to ask,
its a huge advantage to host a server on virtual machine especially if you’re using windows,
especially when it comes to security, i don’t know what is your host OS and if you’re going to use it that way, but if you do comment here and i will provide you a better way to secure your server
and manage it better, as i do.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.