Trying to package Airsonic without success, help requested

en

#1

Since Libresonic has been deprecated in favor of Airsonic, I’m currently attempting to pack the latter, using the installer of Libresonic as a base. However, the installer is still not working, probably because the data structure differs between each other.

The official YunoHost package for Libresonic

My attempt to package Airsonic

You can also ask Massyas, the original packager of Libresonic, who tried to help me package Airsonic as well.


#2

Hello csolisr, the better thing to start would be probably to have a look at the example package. And try to do as its install script. That’ll spare you any common mistakes.

Here you said that you’re install script doesn’t work, but what are the errors or symptoms ?


#3

well, what helped me to start is to learn create a virtual machine with Debian 8 + YunoHost, having an easy way to copy/paste my package and using the great package_check (https://github.com/YunoHost/package_check). Then start by following the example package as Maniack suggested.

This really changes everything.

Process is easy:

  1. Under Linux, I use “Virtual Machine Manager”, and created a virtual machine with it
  2. I changed my “hosts” file and added the link: 192.168.100.186 jb.fr w.jb.fr
  3. I installed and up-to-date YunoHost on it
  4. In my Files manager, I added a link to the server using ssh: ssh://admin@jb.fr it looks like file
  5. Copy paste the package_check code and your package
  6. Run your tests: ./package_check/package_check.sh airsonic_ynh

This will run multiple tests, remember to carefully real the Readme and to correctly write your check_process file: https://github.com/Jibec/package_check#syntax-check_process-file

You can easily ask for package_check to stop on error to see what’s going on: --interrupt

Once it works fine with package_check (basically it install and removes without error), you can go further and run your tests on your virtual machine.

Once it works on both package_check and your virtual machine, you can test it one more time on your personal server :stuck_out_tongue:

Of course, this only is my way of working, and I had no knowledge of sysadmin. (I still have almost none, but at least I did some working packages)


#4

Hello @csolisr and @massyas,

I began to work on an airsonic package and was not aware of your package so I started from scratch in a sandbox.

If you want to have a look and maybe participate, I can publish it soon as it can be installed and removed.

I have a few questions for you as you have experience on this application

  1. I went for the “standalone” version of airsonic as it seems lighter and a simpler setup. What do you think about this?
  2. Have you been able to make airsonic to handle Yunohost users (LDAP integration) ? I am able to see Yunohost users in the airsonic admin panel but I cannot loggin with them. Airsonic logs are really poor with this kibd of error

The main issue I have is with package_check as it cannot test the package properly. The install step fails while it works on a real server. I might have to dig more about this.