Trouble upgrading syncthing

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Yesterday I upgraded syncthing app and the server changed its ID and so all the connections made before were lost.
I could recreate all the connections with the other devices but I needed to make them as new.

Also, there was an error with SSL because the new server refused to connect to an “old” syncthing server coming from a debian stable so I needed to upgrade that server to the testing version (v1.12.1-ds1).

Now everything seems to work, just for advice!

Hi, same issue here, every connections were removed… :confused:
And I got a strange error with the 22000 port which is diagnosed to be unreachable from the internet.
The dashboard of syncthing confirm that there is an error with the port :

However, UPnP is activated on my freebox, but there is no redirection to my server…
I guess I have to manually redirect the port ?

[EDIT] Problem solved : actually in the connection configuration, the listening address was defined to “tcp://default” instead of “default”…

1 Like

I had the same issue and I solved with writing the ip address


but your solution is really better, thanks!

@lnoferin, @Daz, could you share the complete logs of your upgrade? This line takes care of this bug during the install, but it seems it is the first time we encounter it during the upgrade.


This is the log from the webadmin page

Ah! I think @yalh76 caught the issue later that day (cf. PRs Do not change configuration by yalh76 · Pull Request #83 · YunoHost-Apps/syncthing_ynh · GitHub and Update upgrade by yalh76 · Pull Request #84 · YunoHost-Apps/syncthing_ynh · GitHub), so it should not happen during next upgrades. :wink:

1 Like

OK, good to see your reactivity :smiley:
Just in case, here is my log :

A mistake from me.

You can retrieve your previous configuration at /home/yunohost.conf/backup/var/www/syncthing/.config/syncthing/config.xml.backup.XXXXXXX

And you can stop syncthing service, copy the content of the file in //var/www/syncthing/.config/syncthing/config.xml

And restart syncthing service

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.