Tried migrating, now nginx doesn't work - yunohost won't start?

My YunoHost server

Hardware: dedicated server
YunoHost version: can’t check - latest 4.6 version i think
I have access to my server : directly via keyboard

Description of my issue

I updated to the latest version of yunohost available today (9/4) and then tried migrating. The migration didn’t seem to do anything - threw some errors related to some package repos.

I tried to install synaptic to address the issues but it seemed to fail, and now nginx won’t start so I can’t get into ynh.

Also, now when I try to run the yunohost app from the command line it gives me an error not found. message.

No idea what to check from here.

Edit: some logs here hastebin

Output of sudo dpkg --configure -a

Output of journalctl -xe

Yes, sounds like you manually edited /etc/nginx/conf.d/security.conf in the past so it didn’t get updated to the new standard after yunohost got upgraded, and now apparently you managed to uninstall yunohost, which is not supposed to happen because the package is marked as “Essential”, unless you explicitly write “Yes, do as I say” when apt prompts you with it.

@Aleks yep, i definitely did that. omg. i thought i was saying ‘yes’ to overwriting the ssh config with the one from the update, not nginx itself. Linux is not meant for ppl like me :frowning:

If I reinstall, is there any way to recover app data? Main concern is Bitwarden passwords not being lost.

Update: its possible, but I had to have somebody do it for me. Fiverr!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.