Transmission update : backup fail



I tried to update to the newest release of Transmission, but the process is aborted because of a failed backup. A message says that disk space is insufficiant for backing up. I think that it tries to backup the torrent folder, and maybe this is why i get this error.

If someone has an idea ? :slight_smile:
Thanks !

Yes, by default we want to save all the application data, hence the completed/ongoing downloads.
If you really want to avoid that, you can execute the command:

sudo yunohost app setting transmission backup_core_only -v 1

Thank you very much for your reply !


I typed the command to activate backup core only, but when I do

yunohost app upgrade transmission

I get the same error.

Here is the detailed lines of the update (from the end to the beggining) :

Impossible de mettre à jour transmission
Backup failed, the upgrade process was aborted.
+ exit 1
+ echo 'Backup failed, the upgrade process was aborted.'
+ ynh_die 'Backup failed, the upgrade process was aborted.'
+ '[' 5 -eq 0 ']'
L'espace disque est insuffisant sur « /home/yunohost.backup/archives »
+ sudo yunohost backup create --ignore-system --apps transmission --name transmission-pre-upgrade1
+ grep -q transmission-pre-upgrade1
+ sudo yunohost backup list
+ app_bck=transmission
+ old_backup_number=2
+ backup_number=1
+ '[' '!' -e /etc/yunohost/apps/transmission/scripts/backup ']'
+ ynh_backup_before_upgrade
+ sudo yunohost app setting transmission backup_core_only --value=1 --quiet
+ ynh_app_setting_set transmission backup_core_only 1

Thank you again for your help.

Hello Siklaris

Your problem is relative to the backup script, not the upgrade script.
When you make an upgrade, the backup script which is used is the old one. And this old backup script doesn’t know backup_core_only.

So for now, there’s a solution.
You can update manually your backup script.

sudo nano /etc/yunohost/apps/transmission/scripts/backup

And replace the content by the new backup script

EDIT: Bad idea, it doesn’t work…