Transmission max upload size


#1

Hello,

I can’t add a 10,5 GB torrent on Transmission, seems to exceed a limit:

I don’t know what files I could edit to change that limit. I’ve looked here, but didn’t find any line making sense to edit:

$ /etc/nginx/conf.d/domain.com.d/transmission.conf

Should I add a line in this file?
Thanks for your help.


#2

Hi @isidoreisou,

I do not know transmission very well, but I think that you can upload only “.torrent” file. These files are usually small (less than 1 MB).

Are you sure that you are using transmission correctly ?


#3

Hello @toitoinebzh,

Maybe I was not very clear, but I am uploading a .torrent file (855KB), in order to download a 10GB file.


#4

did you had a look at his url https://support.mozilla.org/en-US/questions/1180975
it may be a “cookie” issue


#5

Thanks @toitoinebzh but didn’t solve it.


#6

Hello,

Could you have a look in the log file of nginx please? It should be here:

/var/log/nginx/domain.com-access.log
/var/log/nginx/domain.com-error.log

Taken from https://yunohost.org/#/troubleshooting_guide

Have you tried to add the torrent on a software on your computer? Do you mind sharing the torrent here or in private so I could try to reproduce the issue on my side?


#7

Hello,
Maybe the transmission temp directory is full or too small to store such data?
Could you please connect in SSH to your yunohost server and paste the result of df -h


#8

Thanks for your help @Gofannon

I think I’ve found the line when error occurs:

The torrent can be load locally on my computer on a torrent app without any problem.
It’s from a private tracker so I can’t share this torrent, sorry !
But I think every 10GB+ torrent will reproduce the problem.


#9

Thanks for your help @Benance

I have lot of space on my 2TB hdd on my VPN so I don’t think it’s a problem:


#10

Sorry I spoke to quickly. I’ve just try to upload a 30GB .torrent and it worked. So maybe there is a problem with the .torrent file I’m working with.


#11

yes you have a lot of space on /home, but if transmission temp directory is not located under /home, you don’t have so much space…
Maybe the transmission temp directory is located on /tmp, or something like that. In this case, you don’t have enough place to store a 10g file (7.4g available).


#12

Yes that’s right, for what I see the directory is located in /home/yunohost.transmission/progress so it should be fine.


#13

As I remember the default directory for transmission temp files is located on /var/lib/transmision-daemon/tmp


#14

I thought the progress directory was the same as the temp you mentioned.
Anyway since I’ve tried to upload a 30GB file from a public source and it worked, there is an other problem here, probably linked to the private tracker i’m using.


#15

Hello,

I always had this problem since I use Transmission on YNH (~3 years). Every torrent file above 900KB or so can’t be uploaded using the upload button in Transmission. I always use SFTP and the watched folder when I have to do it.


#16

Thanks @thomas, I did not realize that the problem was coming from the .torrent file size.


#17

You’re welcome but that still doesn’t solve why is there this problem and where we can allow bigger torrent files :grin: