TLS 1.2 not enabled?

Hardware: AMD64

YunoHost version: 11.0.9.913 (stable).

I have access to my server : yes

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description:

Is it true that TLS 1.2 is not enabled? Because I need to do some API stuff to a few of my websites… But, these are failing and most likely due to that issue, if so how can I enable it?

… TLS 1.2 is definitely enabled … It would help if you actually explained what you are trying to achieve, and what actually makes you think that this is the issue …

Please don’t shoot the messenger in this case! We used to have an API between our web shop and our accountancy software, it used to work before, but now it doesn’t. The company which created the accountancy software are the ones which told me that they found out about it, so I will inform them about the fact that they are wrong, and ask them how they found out…

This reminds me an issue in Rocket.Chat involving security setting for NGINX set to “modern”…

Maybe not related at all…

@Aleks can you confirm or deny this please?

Your favorite search engine > TLS test > your domain
I just tried with https://testtls.com/ on my server and I do have TLS 1.2 enabled. (and 1.3 but not 1.0 and 1.1, but you should try with your own domain)

1 Like

What is the output of sudo yunohost settings get security.nginx.compatibility ?

modern

sudo yunohost settings set security.nginx.compatibility -v intermediate
should solve your issue.

1 Like

Yes, you should have read ericg previous link : with modern argument, you disable TLSv1.2, which can cause trouble with Android < 9 and “old” web-browsers.

But we don’t care so much about android and older browsers, sure we want compatibility but rather not over security and besides who is even using android lower than 10 from, the Stone Age or Netscape or whatever version of IE, these days?

But oke job done it worked.

This post had some, stuff in there which i don’t like to be preserved. But it showed the test results and TLS 1.2 was indeed disabled.

THANK YOU ALL! Again now I made the work of doing accountancy obsolete, the API will do that for me now.

So my Shop which I showed of in an earlier post, will be completely automated from adding the products to doing the tax declaration every step in between is never ever being touched by a human again ;-). Now I can finally kick out the accountant which costed me too much. It’s just another job taken over by machines. And maybe one day we only have to wake up and sleep again, since everything in between is not even done by humans anymore… Since fiction is now, becoming the truth!

Ah yes, good old fullyautomatedluxurycommunism_ynh Yunohost app !

1 Like

Look at you @Aleks, you are already having the time to read a book now? Must be so nice to be able to do such a thing.

Bold of you to assume that I read more than the first paragraph of the Wikipedia page :stuck_out_tongue:

2 Likes

I just hoped for it, but hope is the enemy of reality… Should have known better, I’m sorry. :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.