Temporary Lookup Error

hey. gotta love yunohost. been using it for a good while now to run my cluster of gaming/hosting servers. my staff all love the SSO stuff too instead of having like 50 logins for everything we need to get done…

anyway… latest update seems to have broke my email install. i’m not sure how or why but i have a “Temporary Lookup Error” and i’m not sure waht that means, where to look, or how to go about solving it. Let me know what i need to post to help you help me. i dont know what to share… but here’s some things i’ve tried:

  • used the command “sudo newaliases” [not sure what it does but the people on the postfix forum told me to use it. didn’t work and they said to check if /etc/aliases was correct. here’s the entire file… not sure what its supposed to have in it:

    See man 5 aliases for format

    postmaster: root

then theres making sure nslookup my.domain.tld goes through, which it does… all well and good. [my domain is mothnet.xyz and i have all the DNS MX entries correct as its been working until the update.]

and thats about all i’ve tried. haven’t gotten much help so i’m here. some more info: install has been stable for a while. i have nextcloud, pufferpanel, gitlab, and some other “level 8” fully integrated apps installed nothing i installed in or around the time this started happening. i set the server up and its been pretty stable ever since. only noticed the error when adding another alias to my account so that i’d get specific emails sent to me… like support@mothnet.xyz minecraft@mothnet.xyz for our minecraft server support email… warframe@mothnet.xyz and so on so we would have an easy to remember email system… and when some other staff takes charge of a game server/clan we run, the alias would be then removed and given as an alias to them and we wouldn’t have to change anything on the front end. worked perfectly up until adding in the newest “warframe” alias… which was right after updating.

anyway, any help at all would be amazing. let me know what i’d need to post on pastebin and i’ll post it!

Adding on to the problem post, this was in my logs… i guess it just doesn’t like LDAP anymore? some alias problem again which is why they told me to run that command that didn’t work.

Nov 5 09:46:46 mothnet postfix/pickup[14886]: 5346CC81AD4: uid=0 from=
Nov 5 09:46:46 mothnet postfix/cleanup[17017]: warning: ldap:/etc/postfix/ldap-aliases.cf is unavailable. unsupported dictionary type: ldap
Nov 5 09:46:46 mothnet postfix/cleanup[17017]: warning: ldap:/etc/postfix/ldap-aliases.cf lookup error for “moth@mothnet.xyz”
Nov 5 09:46:46 mothnet postfix/cleanup[17017]: warning: 5346CC81AD4: virtual_alias_maps map lookup problem for moth@mothnet.xyz – message not accepted, try again later
Nov 5 09:46:47 mothnet postfix/pickup[14886]: warning: 539E1C81AD4: message has been queued for 3 days

bump.

Uuuuh, does running apt install postfix-ldap --reinstall help ?

here’s the output:

error: object file .git/objects/d8/641bbcfbfe33b32ec686be70e4bf99a4bd92a8 is empty
error: object file .git/objects/d8/641bbcfbfe33b32ec686be70e4bf99a4bd92a8 is empty
fatal: loose object d8641bbcfbfe33b32ec686be70e4bf99a4bd92a8 (stored in .git/objects/d8/641bbcfbfe33b32ec686be70e4bf99a4bd92a8) is corrupt
(Reading database ... 185735 files and directories currently installed.)
Preparing to unpack .../postfix-ldap_3.1.12-0+deb9u1_amd64.deb ...
Removing ldap map entry from /etc/postfix/dynamicmaps.cf
Adding ldap map entry to /etc/postfix/dynamicmaps.cf
Unpacking postfix-ldap (3.1.12-0+deb9u1) over (3.1.12-0+deb9u1) ...
Setting up postfix-ldap (3.1.12-0+deb9u1) ...
Processing triggers for man-db (2.7.6.1-2) ...
error: object file .git/objects/d8/641bbcfbfe33b32ec686be70e4bf99a4bd92a8 is empty
error: object file .git/objects/d8/641bbcfbfe33b32ec686be70e4bf99a4bd92a8 is empty
fatal: loose object d8641bbcfbfe33b32ec686be70e4bf99a4bd92a8 (stored in .git/objects/d8/641bbcfbfe33b32ec686be70e4bf99a4bd92a8) is corrupt

not 100% what that means… or tbh how to find that specific git folder and delete it…. or even if i should do that.

jesus christ. ok never mind. whatever that .git thing was didn’t matter. didn’t even have to reboot, just getting spammed with unread emails from my server and next cloud is able to log in now without error. guess that fixed it. thank you so much!!… so much spam all at once from not being able to check it for about a week. lol… annoying but so very happy its fixed now.

1 Like

Zblerg yea, dunno why reinstalling work even though the package was already installed and therefore stuff should have been working as usuall … Yet that’s not the first time I see some situations like this where a package is installed yet some files that it’s supposed to provide ar e not there and reinstalling fixes the issue …

Anyway, yes that .git thing is probably not important, it’s just etckeeper, and the small mysterious bug you’re experiencing is part of why we’ll remove the dependency in 3.7. In the meantime I think you can safely run rm -rf /etc/.git (though be careful when writing the command)

no kidding. that’s a scary place to run rm -rf. heh. thank you so much! i’m just happy it works perfect now… though i have 183 missed emails OwO now. [i think after an hour or two its finally stopped saying “new email” every 5 seconds.]