Synapse upgrade failed with error

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.6
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I opened the page named like “update system” (my translation). I updated Nextcloud first without problem. Then I tried to update Synapse server to 1.96.1, which ended with an error. The error message was (in my translation from German):

synapse could not be updated: an error has occured in the app upgrade script 

I have no idea how to repair this broken upgrade.

Now, the Synapse server is dead. I’m not sure if it is safe to restart the Synapse service to at least have a running server.

The logs are here:

Hello Matalb,
You have the same error as Iammee

I saw this in your log :
/usr/share/yunohost/helpers.d/fail2ban: Zeile 106: logpath ist nicht gesetzt.

Maybe I have the same error, I still don’t know what to do about fail2ban. I never changed anything with fail2ban manually.

I restarted the fail2ban servicve an started a new upgrade. It still breaks with the same error.

The main question is: what is wrong with the Synapse app update script?

Here is an issue with Yunohost/synapse:

I can’t see a logpath in my fail2ban.conf file.
But, check if you have this, like me :

Option: logtarget
# Notes.: Set the log target. This could be a file, SYSLOG, STDERR or STDOUT.
#         Only one log target can be specified.
#         If you change logtarget from the default value and you are
#         using logrotate -- also adjust or disable rotation in the
#         corresponding configuration file
#         (e.g. /etc/logrotate.d/fail2ban on Debian systems)
logtarget = /var/log/fail2ban.log

Unless it’s in the synapse configuration, that the logpath have to be defined…
Check the synpase configuration file.
I can’t help as it’s not installed for me.

It’s a core bug, nor a package bug ^^"

I try to patch it here: fix the fail2ban helper when using using --use_template arg by OniriCorpe · Pull Request #1743 · YunoHost/yunohost · GitHub


Thank you very much! I’m glad that there was such a quick bugfix.

1 Like

Fixed with the yunohost version 11.2.7 ^w^


I had the same problem. I had an error trying to upgrade synapse.
I did the upgrade to yunohost 1.2.7

# yunohost --version
  repo: stable
  version: 11.2.7
  repo: stable
  version: 11.2.3
  repo: stable
  version: 11.2
  repo: stable
  version: 11.2

But it seems that Synapse was completely removed during the upgrade.
There is my logs :

I tried to restore the pre-upgrade backup but it doesn’t work. (Because the version of yunohost was “too old” ?)

The directory “/home/yunohost/app/synapse” doesn’t exist anymore.

Can I reinstall synapse ? Will I get my data back?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.