Synapse – Server Errors by federation


#41

and

sudo -u postgres /usr/lib/postgresql/9.6/bin/postgres -D /var/lib/postgresql/9.6/main -c config_file=/etc/postgresql/9.6/main/p

#42
root@my:~# sudo -u postgres /usr/lib/postgresql/9.6/bin/postgres -D /var/lib/postgresql/9.6/main -c config_
file=/etc/postgresql/9.6/main/p                                                                            
LOG:  00000: could not change directory to "/root": Permission denied                                      
LOCATION:  resolve_symlinks, exec.c:293                                                                    
postgres: could not access the server configuration file "/etc/postgresql/9.6/main/p": No such file or dire
ctory                                                                                                      
root@my:~#

#44
admin@my:~$ sudo -u postgres /usr/lib/postgresql/9.6/bin/postgres -D /var/lib/postgresql/9.6/main -c config
_file=/etc/postgresql/9.6/main/p                                                                           
                                                                                                           
We trust you have received the usual lecture from the local System                                         
Administrator. It usually boils down to these three things:                                                
                                                                                                           
    #1) Respect the privacy of others.                                                                     
    #2) Think before you type.                                                                             
    #3) With great power comes great responsibility.                                                       
                                                                                                           
[sudo] password for admin:                                                                                 
Sorry, user admin is not allowed to execute '/usr/lib/postgresql/9.6/bin/postgres -D /var/lib/postgresql/9.
6/main -c config_file=/etc/postgresql/9.6/main/p' as postgres on my.domain.tdl                            
admin@my:~$

#45

Meh

Can you do

su postgres

Then you should have a command prompt looking like postgres@tonserveur

Then inside, do

cd

then

/usr/lib/postgresql/9.6/bin/postgres -D /var/lib/postgresql/9.6/main -c config_file=/etc/postgresql/9.6/main/postgresql.conf

#46
root@my:~# su postgres                                                                                          
postgres@my:/root$ cd                                                                                           
postgres@my:~$ /usr/lib/postgresql/9.6/bin/postgres -D /var/lib/postgresql/9.6/main -c config_file=/etc/postgres
ql/9.6/main/postgresql.conf                                                                                     
2019-03-08 19:30:38.204 UTC [7014] LOG:  database system was interrupted; last known up at 2019-03-01 03:20:46 U
TC                                                                                                              
2019-03-08 19:30:38.484 UTC [7014] LOG:  database system was not properly shut down; automatic recovery in progr
ess                                                                                                             
2019-03-08 19:30:38.503 UTC [7014] LOG:  redo starts at 0/14E4FBC8                                              
2019-03-08 19:30:38.514 UTC [7014] LOG:  invalid record length at 0/14E55EA8: wanted 24, got 0                  
2019-03-08 19:30:38.514 UTC [7014] LOG:  redo done at 0/14E55E80                                                
2019-03-08 19:30:38.515 UTC [7014] LOG:  last completed transaction was at log time 2019-03-01 03:21:46.378258+0
0                                                                                                               
2019-03-08 19:30:38.573 UTC [7014] LOG:  MultiXact member wraparound protections are now enabled                
2019-03-08 19:30:38.598 UTC [7013] LOG:  database system is ready to accept connections                         
2019-03-08 19:30:38.601 UTC [7018] LOG:  autovacuum launcher started

#47

Hmmmokay, that oes bring some info about what happened … Though I still don’t understand why the service would not start … If you command is still running, you may stop it with Ctrl + C

Now it you exit and go back to a regular root or admin shell and run sudo systemctl restart postgresql@9.6-main.service, does it still fails ?

And if it still fails, what if you redo this thing with su postgresql, then cd, then the big command … does it still shows the same thing ?


#48
root@my:~# sudo systemctl restart postgresql@9.6-main.service                                                   
Job for postgresql@9.6-main.service failed because the control process exited with error code.                  
See "systemctl status postgresql@9.6-main.service" and "journalctl -xe" for details.                            
root@my:~# su postgres                                                                                          
postgres@my:/root$ cd                                                                                           
postgres@my:~$ /usr/lib/postgresql/9.6/bin/postgres -D /var/lib/postgresql/9.6/main -c config_file=/etc/postgres
ql/9.6/main/postgresql.conf                                                                                     
2019-03-08 20:11:58.802 UTC [7621] LOG:  database system was shut down at 2019-03-08 20:07:39 UTC               
2019-03-08 20:11:58.816 UTC [7621] LOG:  MultiXact member wraparound protections are now enabled                
2019-03-08 20:11:58.844 UTC [7620] LOG:  database system is ready to accept connections                         
2019-03-08 20:11:58.849 UTC [7625] LOG:  autovacuum launcher started

#49

Any more ideas?
Thanks


#50

Thanks for all the help so fare…

after all i did a reinstall of synapse – this worked very well so fare.
RIOT was working

After that I tried as well the new test version

yunohost app upgrade synapse -u https://github.com/YunoHost-Apps/synapse_ynh/tree/testing

this Installation did not work – please have a look

root@my:~# yunohost app upgrade synapse -u https://github.com/YunoHost-Apps/synapse_ynh/tree/testing
Info: Upgrading apps synapse
Info: Upgrading app synapse…
Warning: 8817 /var/lib/matrix-synapse will not be saved, because backup_core_only is set.
Warning: 9419 could not change directory to “/home/yunohost.backup/tmp/synapse-pre-upgrade2/apps/synapse/backup”: Permission denied

What does this mean?

this broke my installation so I had to do a new reinstall

this gave me “the operation ‘Install ‘synapse’ application’ has failed! „

here is the log:
https://paste.yunohost.org/raw/eqoxacider

What Can I do now? – please I need help - Thanks


#51

the Folder /home/yunohost.backup/tmp is no owned by root - is this right?

back-up


#52

I reinstalled postgresql

apt-get --purge remove postgresql\*

and

sudo apt install postgresql

reinstalled synapse and even the testing version
yunohost app upgrade synapse -u https://github.com/YunoHost-Apps/synapse_ynh/tree/testing

successfully – now i will test of federation will work


#53

Josue
Now I run the new testing version of sysapse and it seams I have the same problems with federation as before.

Internal server error

I checked also this site :

https://www.arewereadyyet.com/

which gives me no result at all for my server
What does tht mean?


#54

Probably that your server are not accessible.

Did you check that your server is accessible from internet on the port (generally by default) 8448 ?


#55

Hi Josue
Port 8448 is open in the Router and the Yunohost Firewall

federation with the server http://matrix.org is working – so my server is accessible

but federation with other servers does not work well


#56

Now i checked the sub.domain on my server where i installed the webclient with the test on https://www.arewereadyyet.com/

have a look:

Got 1 connection report

WARN: Self-signed cert found for 93.131.xxx.xxx:8448:, this will need to be replaced in the future [MSC1711](https://github.com/matrix-org/matrix-doc/pull/1711)

INFO: No WellKnownInUse for 93.131.xxx.xxx:8448:

ERROR: on 93.131.xxx.xxx:8448: Checks.AllChecksOK failed

ERROR: on 93.131.xxx.xxx:8448: Checks.MatchingServerName failed

#57

Did you really install the last version from testing ?


#58

Yes I didi it yesterday by

yunohost app upgrade synapse -u https://github.com/YunoHost-Apps/synapse_ynh/tree/testing


#59

Ok,

Did you setup a valid certificat for your server as explained here ? In other words do you use a self-signed certificate ? If yes you need to setup a valid certificate by example with let’s encrypt.


#60

I installed a month ago a certificat with “Let’s Encrypt”
it sayes that it is still valid


#61