Synapse postgres database access using adminer (or anything)

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.8
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: Adminer 4.8.1~ynh6 and Synapse 1.96.1~ynh1

Description of my issue

I am trying to access Synapse’s postgres db using adminer but am unable to. I followed the directions and accessed /etc/yunohost/apps/synapse/settings.yml but it doesn’t show me the database name or username. I do see what I believe is the password though listed under synapse_db_pwd: . I have tried this password in combination with my admin username and a few others. Nothing seems to grant me access to the database though

My goal is to be able to migrate an existing synapse database from just a plain synapse install on another VPS to my yunohost install. If there is an automated process for this that would work too. Thanks in advance!

Database is matrix_signal, user is matrix_signal, password is what you found.

The configuration can be red from homeserver.yaml as per

That worked thank you! :smiling_face_with_three_hearts:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.