Synapse ports are not opening

My YunoHost server

Hardware: VPS bought online.
YunoHost version:
I have access to my server: Through SSH and through the webadmin.
Are you in a special context or did you perform some particular tweaking on your YunoHost instance? : No.

Description of my issue

I attempted to install the synapse app via the webadmin interface- however the service failed to start and could not bind to the ports “8448” and “8008”. Anytime I do anything with the firewall I get the message “Some firewall rule commands have failed. More info in log”, but upon checking both the firewall allowed ports and the log- no issues are present. I have contacted my VPS host and they have confirmed the ports “8448” and “8008” are not blocked on their end. There are a few other services that cannot bind to ports as well.

Synapse service logs: hastebin - homarokifi (

That’s out of my knowledge, but just in case, can you list the network interfaces on the server ?
Just in case there are many and Synapse try to work on the wrong one.
(Synapse and the other non working apps)

Sure, I only have one network interface - ethernet (eth0).

Couldn't listen on ::1:8008: [Errno 99] Cannot assign requested address.

It sounds more like it’s an IPv6-related issue, like IPv6 is completely disabled on your server (even internally ?)

Ah, I think that was part of the problem. I forgot IPv6 existed. Enabling it allowed some ports to work, however others such as "4443 " and "10000 " are still not working. I also noticed even when the ports are allowed the synapse admin api does not function correctly.

I am having the same problem with 4443 and 10000. Everything seems to be working for chat, I haven’t tried voice or video yet though.

I ended up just uninstalling it for now- I’ll reinstall it and post an update about what exactly isn’t working.

Update: The server no longer returns error code 500, now it just returns 404 not found. This happens when I go to the “/_matrix” url. The admin api also returns this 404 not found for some reason. I find this very strange since chat works fine.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.