Synapse login problem using SSO

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.5 (stable)
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I have the server app “Synapse server SSO authentication” running with “Enable password login = yes”. An existing Yunohost user tried to login to the Synapse server. Instead of user name and password, the client app (SchildiChat or Syphon) opened the Yunohost SSO web page, login succeeded.

But on both apps, there is no way to return from the successful Yunohost login web page to the app. I tried myself with th same result. I didn’t try the Element app because now I am afraid not to be able to login again. I am sure that worked ok before.

What can I do?

There is a known bug for exactly this problem, here : Attempting to log in only shows the CAS option, resulting in a loop · Issue #412 · YunoHost-Apps/synapse_ynh · GitHub
You will have to modify 2 files and restart 3 services and it will work.
(I prefer to give a link and not copy the temporary solution because it may change or be solved with something else)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.