Synapse Login + Coturn-Server Problem after update

My YunoHost server

Hardware: VPS Hetzner

YunoHost version: (stable)
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Dear supporters

After the latest two updates, the coturn-server does not start anymore. Manual start does not work either.

Worse is, that it is not possible to login on new sessions.
Last week I restored the app, then it worked again. But I had to login on all instances again.

I think there was a newer update some days later (not sure) which I started, now I have the same problem again.

Anyone has an idea about this? Thanks!

Please use the support template you blatantly ignored. “Latest update” does not cut it.

Other users and I were discussing this in the chatroom earlier. Can you try applying the following patch? It tries to fix the Coturn server.

sudo yunohost app upgrade synapse -u -F

What’s the error in the browser console and in Synapse’s logs?

1 Like

The browser log says: “Could not establish connection. Receiving end does not exist.”

Maybe the same as in the Pastebin:

Not of interest I guess:
The coturn-synapse log after the failed update: hastebin

Hi, the patch failed. Here’s my upgrade log.

I’ve read the logs, I don’t understand why coturn-server doesn’t have the rights to write the lock file.

coturn-synapse.service: Can’t open PID file /run/coturn-synapse/ (yet?) after start: Operation not permitted

I had the same type of issue before the patch.

1 Like

Login works again after I made this: Failed to login after update to v1.65 · Issue #328 · YunoHost-Apps/synapse_ynh · GitHub

Coturn service still doesn’t start.

Last synapse update resolved the coturn issue.
Thank you.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.