Synapse can´t be installed on a shared domain anymore?

By trying to move my synapse installation to an updated server i got same problems. The yunohost backups could not be restored… I tried a lot of things the last days… now also tied a fresh new installation of synapse. But now i get the error warning that synapse can´t be installed on a domain on with also an other yunohost app is running… I use to have Hubzilla and Synapse on the same domain on my old server installation… now this seams not be possible anymore… so all the old matrix account names will not work anymore because i can´t restore synapse on the same domain it just to run…

Is this a new rule: Synapse can´t be installed on a shared domain?
Do you have any idea why i get this error warning?

Did I mess up some settings?
What could I try?

Thanks for help

I can not answer to your question directly, but I can talk about my installation, maybe it can help.

Let’s say my main domain is
I have a Synapse server installed on
But the matrix identifiers of the users on it are

This is due to some DNS stuff explained here : GitHub - YunoHost-Apps/synapse_ynh: Matrix server (synapse) package for YunoHost

And if this is a path you can take, I can share my DNS config if you want.

(On my side, I try to have different sub-domains for each app)

thanks - I could try this for a fresh installation… but if i want to use the backup this would not help.

now I tried an other thing:
I deinstalled the other up/ Hubzilla and tried to do the reinstallation by the synapse backup file.

Now there is an other problem:
WARNING - Command "/opt/yunohost/matrix-synapse/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-55pffjgf/cryptography/';f=getattr(tokenize, 'open', open)(__file__);'\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-wxddovis/install-record.txt --single-version-externally-managed --compile --install-headers /opt/yunohost/matrix-synapse/include/site/python3.7/cryptography" failed with error code 1 in /tmp/pip-install-55pffjgf/cryptography/

how could i fix this? Thanks

What is the version of synapse you try to restore ?
There was recently many problems in the synapse restore scripts.

From the log script, it seems that this is possible.

Can you first try what is suggested here : Upgrade and restoration fails : ImportError: cannot import name '\''_PY3'\'' from '\''twisted.python.compat'\'' (unknown location) · Issue #246 · YunoHost-Apps/synapse_ynh · GitHub
(I’ve done it, without any consequences, and was then able to restore a backup)

If this is not enough, this issue may be closer to your problem, but I’ve seen people with problems caused by the manual installation of Rust, so I am not sure this is the good way :

You will have to dig this, and I hope you will find a way.
It may be fixed in last Synapse version, but not in the version you try to restore.

@Mamie Thanks so much for your good hints…

just found out that if synapse is installed first - hubzilla can be installed as second app with out a problem to the same domain - so i can work on with the backup files …

i just tried

$ mkdir /tmp/synapse-backup
$ cd /tmp/synapse-backup
$ tar xf /home/yunohost.backup/archives/my-synapse-backup.tar
$ nano ./apps/synapse/settings/scripts/
<Change line to:
`pip3 install --upgrade 'Twisted>=20.3.0<21' matrix-synapse==$upstream_version matrix-synapse-ldap3`
$ tar cf /home/yunohost.backup/archives/new-synapse-backup.tar *
$ yunohost backup restore new-synapse-backup --apps

and still got

Warning: Command "/opt/yunohost/matrix-synapse/bin/python3 -u -c "import setuptools, tokenize;__file__='/
tmp/pip-install-6x63nxao/cryptography/';f=getattr(tokenize, 'open', open)(__file__);
.replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-
p1qapnik/install-record.txt --single-version-externally-managed --compile --install-headers /opt/yunohost
/matrix-synapse/include/site/python3.7/cryptography" failed with error code 1 in /tmp/pip-install-6x63nxa

now it will try this fix:

hope this will help…

looks much better now - but still it did not work

chown: invalid user: ‘matrix-synapse:root

Is this what has to be fixed? How can I do it?

just tried with an other backup file - the debug log looks a bit different

does this tell anything new?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.