Synapse app on Raspberry pi 4 running Yunohost 4.0.3

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: 4.0.3
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I want to run my own matrix server and connect using the element client app (mostly family members, so a very small group of people) but I can’t install the synapse app, after failed install I see the following error:

Could not install synapse: An error occurred inside the app installation script

and then everything is deleted

Complete log here because I exceeded the character limit: Complete log link

This is my configuration (taken from complete log):

  app: synapse
  args: domain=maindomain.tld&server_name=Same%20than%20the%20domain&
  force: false
  label: Synapse
  no_remove_on_failure: false
ended_at: 2020-08-04 20:32:59.805567
  YNH_APP_ARG_DOMAIN: maindomain.tld
  YNH_APP_ARG_SERVER_NAME: Same than the domain
  YNH_APP_ID: synapse
  YNH_CWD: /var/cache/yunohost/from_file/synapse_ynh-813dac3a2b7e81ed57620e1971b9a297df429224/scripts
  YNH_STDINFO: /tmp/tmpLxioab/stdinfo
  YNH_STDRETURN: /tmp/tmptWqnxV/stdreturn
error: An error occurred inside the app installation script
operation: app_install
- - app
  - synapse
started_at: 2020-08-04 20:31:17.176106
success: false
yunohost_version: 4.0.3


I also saw the following warnings and errors (taken from complete log):

2020-08-04 22:32:04,403: WARNING - I: Creating /var/lib/turn/turndb from /usr/share/doc/coturn/schema.sql
2020-08-04 22:32:09,115: WARNING - Created symlink /etc/systemd/system/ -> /lib/systemd/system/coturn.service.
2020-08-04 22:32:59,271: WARNING - /opt/yunohost/matrix-synapse/bin/activate: line 31: $1: unbound variable
2020-08-04 22:32:59,804: ERROR - Could not install synapse: An error occurred inside the app installation script

Any pointers and help is greatly appreciated

Hello, I did some fix on the testing branch

Can you try it ?

1 Like

I really appreciate the help, I first assumed you meant to install the app using the install custom app option

I tried pasting the link and got the following output on my administration tab:

No manifest.json file

However I see the file listed.

I tried using the command: sudo yunohost app install --debug

And that seems to do the trick

Here is the complete log if you find it useful

Am I correct in assuming that I’ll have to do sudo yunohost app upgrade synapse to switch back to the stable release branch?

Thank you so much for the help! Yunohost is great even for non sys-admins like me!

Hey there,

In order to install the testing branch of synapse, use this command :
sudo yunohost app install --debug

(I’m facing the same issue and it worked for me)

Good luck !

Yes, that’s exactly what I did and it worked, I was just providing an additional log and wondering what to do after this is in the main branch “how to go back to stable once it is”

Followup question @Josue , any reason for my server to not be discoverable? I checked that the federation port (8448) is opened by issuing sudo yunohost firewall reload and port forwarding is correctly set up in my router.

Happy to provide any logs or information if someone is willing to help as well.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.