Support needed: ownCloud, Searx, Jirafeau and general questions

First of all, Thanks for the amazing tool! Yunohost is really great. It`s hard to find a self-hosted software designed for “normal” people.

My name is Jorge, I’m architect in Brazil, and installed Yunohost in my home PC, using Hyper-V (Virtual Machine) on Windows 8.1 and I’m facing some problems:


  • My admin page shows a mix of English and Portuguese. I chose to install it in English for better troubleshooting, but now it shows English and Portuguese. Its not a real problem to me, but I think its worth mentioning.

  • Every time I try to install a new app my domain and users list are empty.

After click manage domains and click back the list show my domain. The same for user accounts. Is it OK?

  • How can I access my user dashboard directly? Should I always access a “service” like wallabag or torrent first and then go to the dashboard?

  • Does Yunohost supports local file sharing? Like:

Windows Explorer->Network Places-> YunoHost Server-> Shared Folder

Specific Help:

  • I installed searx and I get this error message when I try to access it in Firefox 38.0.1:

502 Bad Gateway

The installation process was successful and I got no error messages.

  • I tried to install owncloud and it failed once, then I tried again and received the following message:
  • set -e
  • path=/owncloud+ user=jguimaraes
  • grep -qi ‘“username”: “jguimaraes”’
  • sudo yunohost user list --json
  • sudo yunohost app setting owncloud admin_user -v jguimaraes
  • sudo yunohost app checkurl -a owncloud
  • path=/owncloud+ sudo apt-get update -qq
  • sudo apt-get install acl smbclient -y -qq
    ++ tr -c -d A-Za-z0-9
    ++ dd if=/dev/urandom bs=1 count=200++ sed -n ‘s/(.{24}).*/\1/p’
  • db_pwd=R8E2GMaCerShCBZgi4QKkz2Z
  • db_user=owncloud
  • sudo yunohost app initdb owncloud -p R8E2GMaCerShCBZgi4QKkz2Z
    ERROR 1007 (HY000) at line 1: Can’t create database ‘owncloud’; database exists
    Error: MySQL database creation failed

Even after this error message, I saw the owncloud icon on my user dashboard once, accessed the site, but then it redirected me to the dashboard again and the icon disappeared. :no_mouth:

  • Jirafeau: Oh, this one is really simple! I set an upload password, but the app refuses to accept :cry:
    I installed, removed, installed again and nothing. I access the admin page with no problems, but there I cant set a new password.
    edit: I found my problem.

The password must not contain special chars.

edit 2:
FYI: Jirafeau doesn’t shows the yunohost link to SSO (small gray dragable rectangle)


  • Calibre ( is an interesting software to manage ebooks and comics.
  • Ubooquity ( is similar to Calibre, fewer options but lighter and (maybe) easier to implement. I know nothing about installing software in linux, and did it smoothly on a Turnkey linux VM (
  • This forum could have an off-topic section, so people could present themselves, and ask where is the proper section to post :smile:. You know…

Thanks for report. You can create an issue on github if you want, it would be more easier to handle.

It is an expected behaviour, and all the users will have access to the newly installed application.

I use to type “” and it does redirect me to the login panel. Any unknown URL would throw you to the login page.

Yunohost is debian-based. You could search about debian file sharing with Windows machines. I think something like samba to share your files and printers would do the trick.

Can you provide the log files, usually placed at

   /var/log/nginx/<domain>-access.log   /var/log/nginx/<domain>-error.log


You need to drop the previous database called ‘owncloud’ that was created with your previous installation of owncloud. Either install phpmyadmin (via yunohost and github) or use the mysql command line to drop it :

mysql -uroot -p 

and type the password placed in the


file, and then do


It depends if you set the application as publicly accessible in the installation process. If yes, then it’s an expected behaviour. If you really want it, you can add

# Include SSOWAT user panel.
include conf.d/;

into the


file and do

nginx -s reload

You can add your suggestions into the wish-list available here (make a pull-request on github) .

Thanks for report :slight_smile:

Hi @matlink , thanks for all answers!

So, here we go:

Please, confirm if yunohost-admin is the right place.

I know Samba. I confess I tried set it up before, but with no success. I’ll try it and then report my success (I wish).

BTW, I dont know if my profile represents the “common” YunoHost user, but it would be very nice if it comes working by default.

Think about it: I have a server at my home (my pc) so I can physically access the pc. Why not grab my Transmission downloads by drag-n-drop?


I dropped database owncloud, and tried to install again, but now I got the following error:

useradd: user ‘owncloud’ already exists

Then I tried to delete user and got other error:

admin@dhcppc8:~$ sudo userdel owncloud
userdel: user owncloud is currently used by process 7780
admin@dhcppc8:~$ ps ax | grep 7780
7780 ? S 0:00 php-fpm: pool owncloud
10429 pts/0 S+ 0:00 grep 7780

I added them to the wishlist. I didn’t know it is that easy :smiley:

Thanks again!


You almost can, since Transmission has a “download” section to grab the downloaded files via HTTP.

The file you gave are not the ones I’m looking for. You should give the ones that are called “-acces.log” and “-error.log”

kill the process with PID 7780

kill -9 7780

Ok :smile: here is > -access.log and here is -error.log

About owncloud:

I tried to kill the php-fpm process, but it replicates itself, so I stopped it using

sudo service php5-fpm stop

And then deleted owncloud user

sudo userdel owncloud

Also, I found (under ngnix logs) an owncloud log..
Now, I’m facing another problem, I can’t access my server form name domain, only by LAN address. This way I still can’t install. I’ll try later!