Suite à mise à jour Hotspot Wifi ... plus de hotspot

My YunoHost server

Hardware: Brique Internet Olimex
YunoHost version: 4.3.2.2 (stable)

Description of my issue

Suite à la mise de ynh-hotspot je n’arrive plus à me connecter au hotspot dans les logs du service j’ai :

Nov 11 18:44:33 ynh-hotspot[12828]: hotspot0: Set IPv6 firewalling
Nov 11 18:44:33 ynh-hotspot[12828]: hotspot0: Start the NDP and DHCPv6 server (dnsmasq)
Nov 11 18:44:33 ynh-hotspot[12828]: dnsmasq: bad IPv6 address at line 23 of /etc/dnsmasq.dhcpd/dhcpdv6-ssid0.conf
Nov 11 18:44:33 dnsmasq[12958]: bad IPv6 address at line 23 of /etc/dnsmasq.dhcpd/dhcpdv6-ssid0.conf
Nov 11 18:44:33 dnsmasq[12958]: FAILED to start up
Nov 11 18:44:33 ynh-hotspot[12828]: hotspot0: Start the DHCPv4 server (dnsmasq)
Nov 11 18:44:33 ynh-hotspot[12828]: dnsmasq: bad IP address at line 22 of /etc/dnsmasq.dhcpd/dhcpdv4-ssid0.conf
Nov 11 18:44:33 dnsmasq[12968]: bad IP address at line 22 of /etc/dnsmasq.dhcpd/dhcpdv4-ssid0.conf
Nov 11 18:44:33 dnsmasq[12968]: FAILED to start up
Nov 11 18:44:34 systemd[1]: Started YunoHost Wifi Hotspot
/etc/dnsmasq.dhcpd/dhcpdv6-ssid0.conf au ligne 22 et 23 j'ai  : 

# Send DHCPv4 option.
dhcp-option=option:dns-server,
et 
# Send DHCPv6 option. Note [] around IPv6 addresses.
dhcp-option=option6:dns-server,

Je ne vois pas ce qui ne va pas …

Autre info, j’ai lancé : journalctl -f -u dnsmasq

-- Logs begin at Thu 2021-11-11 13:52:18 CET. --
systemd[1]: Starting dnsmasq - A lightweight DHCP and caching DNS server...
dnsmasq[14188]: dnsmasq: syntax check OK.
dnsmasq[14198]: started, version 2.80 cachesize 256
dnsmasq[14198]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify dumpfile
ndnsmasq[14198]: reading /etc/resolv.dnsmasq.conf
ndnsmasq[14198]: using nameserver <IPV6>::40#53
dnsmasq[14198]: using nameserver <IPV4>#53
dnsmasq[14198]: read /etc/hosts - 7 addresses
dnsmasq[14199]: /etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symbolic link to /etc/resolvconf/run/resolv.conf
systemd[1]: Started dnsmasq - A lightweight DHCP and caching DNS server.

(j'ai remplacé les adresses IP par < IPV6 > et < IPV4 >)

J’ai fini par ajouter dans yunohost/admin/#/apps/hotspot/config-panel
puis advanced settings / DNS resolvers les adresses IP (ipv4 et v6) de mes DNS, j’ai sauvegardé, relancer le hotspot et ça fonctionne. Mais j’ai dans les logs ces erreurs :


Nov 11 19:34:02 dnsmasq[2144]: LOUD WARNING: listening on <ip dns> may accept requests via interfaces other than tun0
Nov 11 19:34:02 dnsmasq[2144]: LOUD WARNING: use --bind-dynamic rather than --bind-interfaces to avoid DNS amplification attacks via these interface(s)
Nov 11 19:34:02 dnsmasq-dhcp[2144]: DHCP, IP range 10.0.242.2 -- 10.0.242.254, lease time 4h
Nov 11 19:34:02 dnsmasq[2144]: LOUD WARNING: listening on <ip dns> may accept requests via interfaces other than tun0
Nov 11 19:34:02 dnsmasq[2144]: LOUD WARNING: use --bind-dynamic rather than --bind-interfaces to avoid DNS amplification attacks via these interface(s)
Nov 11 19:34:02 dnsmasq[2144]: LOUD WARNING: listening on <ip dns> may accept requests via interfaces other than tun0
Nov 11 19:34:02 dnsmasq[2144]: LOUD WARNING: use --bind-dynamic rather than --bind-interfaces to avoid DNS amplification attacks via these interface(s)
Nov 11 19:34:03 systemd[1]: Started YunoHost Wifi Hotspot.
Nov 11 19:34:03 dnsmasq[2144]: LOUD WARNING: listening on <ip dns> may accept requests via interfaces other than tun0
Nov 11 19:34:03 dnsmasq[2144]: LOUD WARNING: use --bind-dynamic rather than --bind-interfaces to avoid DNS amplification attacks via these interface(s)
Nov 11 19:34:03 dnsmasq-dhcp[2144]: DHCPREQUEST(wlan0) 10.0.242.28 <MAC>
Nov 11 19:34:03 dnsmasq-dhcp[2144]: DHCPACK(wlan0) 10.0.242.28 <MAC> EX6130
Nov 11 19:34:03 dnsmasq[2144]: LOUD WARNING: listening on <ip dns> may accept requests via interfaces other than tun0
Nov 11 19:34:03 dnsmasq[2144]: LOUD WARNING: use --bind-dynamic rather than --bind-interfaces to avoid DNS amplification attacks via these interface(s)

Mais je ne vois pas comment/où mettre l’option --bind-dynamic à la place de --bind-interfaces …

Bonjour,

Je me permets de suivre ce post car je rencontre le même problème depuis la MaJ de cette application.

Le signal wifi est bien présent mais impossible de s’y connecter. J’avais également un soucis avec les champs DNS vides, mais même en y indiquant différentes adresses (LDN, Google ou OpenDNS) je n’arrive toujours pas à me connecter sur le réseau.

Merci pour votre aide !

Bonjour,
Après une mise à jour de Hotspot, je rencontre le me problème :
dnsmasq: bad IP address at line 22 of /etc/dnsmasq.dhcpd/dhcpdv4-ssid0.conf
La ligne 22 est la suivante :
dhcp-option=option:dns-server,
Je note aussi que je n’ai pas d’option pour l’IPv6.

Je vais la désinstallation et la réinstallation du hotspot pour voir…

Je sais, c’est un petit peu bourrin.

:wink:

Ce matin à nouveau le problème de VPN :slight_smile:


[CRIT] Failed to start OpenVPN client : tun0 interface did not show up
systemd[1]: ynh-vpnclient.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: ynh-vpnclient.service: Failed with result 'exit-code'.
systemd[1]: Failed to start YunoHost VPN Client..

et c’est tous les jours la même chose …

Impossible de relancer le service ynh-vpnclient via l’interface d’administration, je suis obligé de redémarrer la brique.

Est-ce que tu peux expliquer pourquoi c’est impossible, qu’est-ce qui se passe quand tu essaies ?

Je viens d’avoir le cas à l’instant. Donc le client vpn ne se lance plus.

sur la page “services” j’ai :


**Description**
Tunnels the internet traffic through a VPN
**Statut**
failed depuis il y a 1 minute

Quand je clique sur le bouton “Démarrer” j’ai l’erreur suivante :

**Erreur**: `"500" Internal Server Error`
**Action**: `"PUT" /yunohost/api/services/ynh-vpnclient/start`

et dans le détails un truc interminable qui se termine par :

[INFO] Stopping OpenVPN service 
ynh-vpnclient[23923]: [CRIT] Failed to start OpenVPN client : tun0 interface did not show up
systemd[1]: ynh-vpnclient.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: ynh-vpnclient.service: Failed with result 'exit-code'.
systemd[1]: Failed to start YunoHost VPN Client..

tous les détails ici : https://paste.yunohost.org/nocurusaga

Salut harpogit,

Est-ce que ça a réglé le soucis ?

Bonjour @Sty_X

Je pense que oui.
J’ai attendu avant de répondre car j’ai d’autes petits soucis qui y sont peut-être liés, que je vais essayer de creuser ce week-end.
Merci !

J’ai testé la désinstallation / réinstallation est cela n’a pas marché pour moi… Le signal wifi est bien visible mais impossible de s’y connecter.

C’est donc un problème VPN, j’ai fait suite à ce problème ici : https://forum.yunohost.org/t/probleme-configuration-vpn-client/17849/8

Merci pour ta réponse !

J’ai bien mis à jour l’app VPN mais je n’arrive toujours pas à me connecter via le hotspot. Signal bien visible mais connexion impossible…

Je viens de passer la testing hotspot_ynh en version stable.

Est-ce que la mise à jour fonctionne mieux ?

Salut ljf,

J’avais désinstallé l’app, je viens de la réinstallée mais je ne sais pas si elle prend déjà en compte tes dernières modifications. il s’agit de la version 2.0~ynh3.

En tout cas avec cette version ça ne fonctionne toujours pas.

J’ai bien 10.0.242.1 en DNS resolver. Lorsque j’essaie de désactiver puis réactiver le réseau j’ai ces message d’erreurs :

RTNETLINK answers: File exists
Device “wlp1s0|wlp4s0” does not exist.
“” is invalid lladdr.
Cannot find device “wlp1s0|wlp4s0”
Cannot find device “wlp1s0|wlp4s0”
dnsmasq: mauvaise adresse IPv6 à la ligne 6 de /etc/dnsmasq.dhcpd/dhcpdv6-ssid0.conf

Il semble y avoir un soucis au niveau de la carte wifi (une TP-LINK TL-WDN4800) qui fonctionnait sans soucis avec l’ancienne version de l’app.

Concernant le fichier /etc/dnsmasq.dhcpd/dhcpdv6-ssid0.conf, voici ce qu’il contient :

# Do DHCP and Router Advertisements for this subnet. Set the A bit in the RA
# so that clients can use SLAAC addresses as well as DHCP ones.
dhcp-range=interface:wlp1s0,2001:913:c10::,slaac,64,4h

# Send DHCPv6 option. Note [] around IPv6 addresses.
dhcp-option=option6:dns-server,

Merci de ton aide !

PS : je me rends compte que même lorsque je désactive le hotspot via la page de config d de l’application. Le réseau est toujours visible depuis mon ordinateur…

Je suppose du coup que tu as 2 antennes ?

J’ai d’office 2 connecteurs SMA sur la carte mère pour le chipset embarqué. Que je n’utilise pas et qui est désactivé dans le bios.

Puis j’ai 3 connecteurs SMA sur la carte wifi TP-Link. J’y ai donc 3 antennes de connectées.