Subdomain setting off privacy error

I have installed a subdomain that contains the custom webapp application. I have installed a lets encrypt SSL for main domain, but lets encrypt times out whenever I try to install a SSL for the subdomain – It won’t let me even try to install the SSL through the admin panel, and when I try the command line command “sudo yunohost domain cert-install --no-checks” the script timeouts and also provides the error: “Error: Wrote file to /tmp/acme-challenge-public/epSNrCSzg4wybVSU6gZ2fTROob5MH6uf3_e2lpbMeJk, but couldn’t download http://[my subdomain]/.well-known/acme-challenge/epSNrCSzg4wybVSU6gZ2fTROob5MH6uf3_e2lpbMeJk

When I visit the subdomain in browser, chrome will not open the website and instead gives me the error: “You cannot visit [my subdomain] right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.” Firefox also gives me an error, “Your connection is not secure”, but I’m able to add an exception and the site shows the custom webapp generated index page with the sftp connection info.

For the life of me, I can’t figure out what I am doing wrong. Thank you for your help.

My YunoHost configuration

Hardware: x64 – 2008 iMac
Internet access: ethernet at home
YunoHost version:
yunohost-admin: 3.0.0
moulinette: 3.0.0
ssowat: 3.0.0
Have you personalized your yunohost with some specifics configurations or do you use only the yunohost cli/webadmin tool ? basic – added ddclient
If personalized, how: Added DDClient to update namecheap dynamic dns

Description of my problem

All I’m trying to do is to get my subdomain working with an SSL from lets encrypt, but lets encrypt timeouts and I continue to get “this site is not secure” messages.

This issue has been solved. I swear that I went through every message I could find on both this forum and Google, and I couldn’t find anything. Then 10 minutes after posting, I noticed a similar topic that provided the answer. Thank you and sorry.

The answer was from:

What I did:
I ran the command “yunohost service regen-conf dnsmasq” and then ran the command “sudo yunohost domain cert-install [my subdomain] --no-checks” and it worked!

This may be deleted or marked as resolved. Thank you for the awesome package!