Step: Select and install software failed

#1

My YunoHost server

Hardware: LG R405 Core2Duo 1,6Ghz, 3Gb RAM
YunoHost version: 3.4.2.2-amd64-stable / 3.4.2.2-i386-stable
I have access to my server : No, no possibility of logging in
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi!
I’ve been interested in self-hosting for quite some time and the other day I stumbled across a Yunohost flyer while strolling around town. I was curious to see what it could offer as opposed to a standard Debian server so I decided to give it a try.
After downloading the image and flashing it with dd with bs=1024k on a SanDisk Cruzer 16Gb stick, I started installing on an old laptop I’ve got lying around for a rainy day.
To my dismay, after partitioning the HDD and entering the “Select and install software” step of the process, the installer fails with a simple message of “step failed, skip it or retry”.
Retrying the step takes quite a while longer for some reason, but ends up in the same way every time.
I attempted using both the 32bit and 64bit versions of the installer with the same results for both Expert and Graphical installer modes.
If choosing to skip the install software step, I end up a a standard Debian login screen without the possibility of logging in. “Not listed” is the only user and none of the “default” username/password configurations I could find for either Debian nor Yunohost worked for logging in.

Couldn’t manage to find any install logs on the USB key I used for installing, and since I can’t login I sadly couldn’t get any logs from the HDD either.
Please help a brother out fam.

/M

#2

So you flashed the pre-installed x86 ISO available in the doc ?

Not sure why it did not work, but I do understand your dismay as it happened to me a while ago trying to debug stuff and it was a pain in the ass to get the actual reason for the failure …

Anyway, I’m thinking a workaround could be to install a regular debian then install yunohost on top of it with https://yunohost.org/#/install_manually

1 Like
#3

Thx Buddy, hadn’t found that article!
Realised the installer allowed me to go back a few steps and set my user & pass after failing the software step. I was finally able to log in to my vanilla Debian! :slight_smile:

this manual install method worked after installing apt-transport-https (apparently Curl doesn’t handle https by default (?))