Stealth vpn via OpenVPN on TCP port 80

Hi, this this script works great however im unable to use port 80 on my yunohost server. I assume this is because Juno wants to use http. Is there any way I can tell yunohost to only use 443/https so that I can run a vpn on port 80 to get around DPI? Thanks

Hello, no. Port 80 is mandatory and cannot be disabled. It is required for Let’s Encrypt certificates generation.

Have you considered Zerotier and Ztncui (“server” for Zerotier)? It handles “hole punching”/“NAT traversal” and defaults to port 443 if needed.

crap that’s something I didn’t consider. I had thought LE could verify through 443. That being said could it still be possible if I authored by dns with LE instead? I haven’t looked into zertotier but I will do that too

I have tried zerotier with ztncui. it works well to link lans but forwarding all internet traffic like a traditional VPN would is a bit complicated. I tried following the official directions but it doesn’t work with Debian.