SSL error, and Let's Encrypt certificate installation fails

My YunoHost server

Hardware: Old computer
YunoHost version: 11.2.4
I have access to my server : Through SSH + through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

  1. Having just finished installing Yunohost from USB stick, it was ready to go and worked well on the LAN using the host IP address.
  2. In the web frontend, I chose an unused subdomain and it made a self-signed certificate.
  3. Problem: Visiting the domain gives a browser error “ERR_SSL_UNRECOGNIZED_NAME_ALERT”.
  4. I get errors while trying to get a Let’s Encrypt certificate (pastebin).
  5. Upon searching, I found this relevant post which indicated that values needed to be manually added to /etc/hosts, so I did that:       jag15
  1. Now the Let’s Encrypt creation completes (see first image below) but somehow does not get activated (see second image below). As a result, I am still not able to reach my Yunohost via the domain name.
  2. The file /etc/hosts seems unchanged from the quote above. An SSL checker says “No SSL certificates were found on this domain.
  3. As a workaround, I edited my local Windows hosts file, but of course this does not solve the issue itself (only for me):

(1) LE certificate is signed:
(2) LE certificate is not activated:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.