SSH ok, but SFTP not

,

Hello,

When I try to connect using Filezilla, I always get an error :

Statut : Connexion à mydomain.tld…
Réponse : fzSftp started, protocol_version=8
Commande : open “admin@mydomain.tld” 22
Erreur : Server sent disconnect message
Erreur : type 2 (protocol error):
Erreur : “Too many authentication failures”
Erreur : Impossible d’établir une connexion au serveur

It happens every time I try to connect using Filezilla, no problem accessing via terminal ssh admin@mondomain.tld …

Could you help me ?

There is a dedicated page about using FileZilla if it can helps : https://yunohost.org/#/filezilla

Carefull to don’t fail “too much” while login as YunoHost will “ban you temporaly” out of your server to avoid bruteforce

Hello Gofannon,

I have followed the tutorial, but even after a few days I get the same error message … “Too many authentication failures”.
I use Filezilla to connect to other servers without problems.

In the file2ban log I can see :
2020-09-22 08:42:28,539 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:28,540 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:28,540 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:28,540 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:28,541 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:28,542 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:28,578 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:33,587 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:33,588 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:33,588 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:33,588 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:33,589 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:33,589 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip
2020-09-22 08:42:33,591 fail2ban.filter [1512]: INFO [sshd] Ignore XX.YY.ZZZ.AA by ip

where XX.YY.ZZZ.AA is my IP … I have pressed only once on “connect” in Filezilla, but I can see 14 connection attempts in a few seconds. Maybe a setting in Filezilla or in Fail2Ban ?

Maybe you have a lot of private key in ~/.ssh/ ?
Edit: i splited your topic cause the other one is marked as solved.

1 Like

Hello ljf, yes you are right, there are 14 ssh private keys in ~/.ssh/ … matching the number of connection attemps (14).
When I use a ssh private key on other servers, Filezilla usually asking to convert the file into Filezilla format, but it is not the case here. I have a connection using user : admin + password.
What shall I do then ? Do I need to change something in Filezilla in order to prevent this behavior ?

I don’t know exactlywhat you should do but if i remember there is an option to specify a specific key in filezilla configuration.

I wanted to stay with an “admin / pass” type of connection. The problem has been spotted, I will try to find a solution…
My goal was to upload two big video file (200Mo each) from my PC to the server (on a wordpress site). I usually edit the files via terminal but when I need to upload big files I usually use filezilla.

Thanks for your help :slight_smile: , if you find more info …

Which Operating system are you using? Windows, Linux, Mac?


I found some people who have the same problem, you could find some help there: (specifically the pageant part)

You can put FileZila in “debug mode” to see more about the issue : https://wiki.filezilla-project.org/Logs#Changing_the_verbosity

Also, you could try another software to see if it works better for you, depending of your system

edit: I’m late :slight_smile:

Hello,
I am on a linux debian 10 and have filezilla 3.39

the debug message :

Statut : Connexion à mondomaine.tld…
Suivi : CControlSocket::SendNextCommand()
Suivi : CSftpDeleteOpData::Send() in state 0
Suivi : Going to execute /usr/bin/fzsftp
Réponse : fzSftp started, protocol_version=8
Suivi : CSftpDeleteOpData::ParseResponse() in state 0
Suivi : CControlSocket::SendNextCommand()
Suivi : CSftpDeleteOpData::Send() in state 3
Commande : open “admin@mondomaine.tld” 22
Suivi : Connecting to XX.XXX.XX.XX port 22
Suivi : We claim version: SSH-2.0-FileZilla_3.39.0
Suivi : Server version: SSH-2.0-OpenSSH_7.4p1 Debian-10+deb9u7
Suivi : Using SSH protocol version 2
Suivi : Doing ECDH key exchange with curve Curve25519 and hash SHA-256
Suivi : Server also has ecdsa-sha2-nistp256/ssh-rsa host keys, but we don’t know any of them
Suivi : Host key fingerprint is:
Suivi : ssh-xxxxxxx 256 3-:qq:–:13:aa:–:82:2d:–:1a:41:3c:www:73:69:e8 --------------------------------
Suivi : Initialised AES-256 GCM client->server encryption
Suivi : Initialised AES256 GCM client->server MAC algorithm (in ETM mode) (required by cipher)
Suivi : Initialised AES-256 GCM server->client encryption
Suivi : Initialised AES256 GCM server->client MAC algorithm (in ETM mode) (required by cipher)
Suivi : Pageant is running. Requesting keys.
Suivi : Pageant has 6 SSH-2 keys
Suivi : Trying Pageant key #0
Suivi : Server refused our key
Suivi : Trying Pageant key #1
Suivi : Server refused our key
Suivi : Trying Pageant key #2
Suivi : Server refused our key
Suivi : Trying Pageant key #3
Suivi : Server refused our key
Suivi : Trying Pageant key #4
Suivi : Server refused our key
Suivi : Trying Pageant key #5
Suivi : Received disconnect message (protocol error)
Suivi : Disconnection message text: Too many authentication failures
Suivi : Server sent disconnect message
Suivi : type 2 (protocol error):
Suivi : “Too many authentication failures”
Erreur : Server sent disconnect message
Erreur : type 2 (protocol error):
Erreur : “Too many authentication failures”
Suivi : CSftpControlSocket::OnTerminate without error
Suivi : CControlSocket::DoClose(66)
Suivi : CControlSocket::ResetOperation(66)
Suivi : CSftpDeleteOpData::Reset(66) in state 3
Erreur : Impossible d’établir une connexion au serveur
Suivi : CFileZillaEnginePrivate::ResetOperation(66)
Statut : Attente avant nouvel essai…
Suivi : CControlSocket::DoClose(66)
Suivi : CControlSocket::DoClose(66)

Pageant has 6 keys and Filezilla tries to use each key to connect to your server.
YunoHost disconnects you after the fith try.

You need to either 1) stop pageant if you don’t use it or 2) find a way to tell filezilla to don’t use pageant and it’s ssh keys

Hello,
I did not find how to set the parameters in filezilla. The setting for “logon type” is “ask for password” but the behavior is not as requested… a bug ? an unknown setting ? I don’t know :thinking:
This will need more investigation but since I need a solution I have uploaded my big files to worpdress with sshfs and it worked just fine.

Thank you very much for your help and time !

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.