SPF for inbound e-mails should be default

Hello everyone,

I received a very basic spam, using my e-mail address as sender and recipient. This is not normal because SPF should not allow this, this spam should have been rejected.

I quickly realized that there is no SPF in my Postfix configuration. So I manually installed postfix-policyd-spf-python and edited main.cf and master.cf. Now SPF is working for inbound e-mails. But a Yunohost update may remove these…

I think this should be default in Yunohost, I don’t see any reason to run a mail server without SPF checking.

Is it just me or Yunohost does not enable SPF check by default ?

My YunoHost configuration

Hardware: x64 vps
Internet access: in a datacenter
YunoHost version:
yunohost-admin: 3.4.2
moulinette: 3.4.2
ssowat: 3.4.2

Hmmmyes I think we never had so much expertise about fighting spam on the mail stack (it’s already complicated to find the motivation to work on the mail stack, let alone more advanced stuff :stuck_out_tongue_winking_eye: )

If you can open an issue detailing what you did exactly (or even better, a PR, even if it has missing pieces) would be totally awesome so we can integrate that :wink:

We also have rspamd which supposedly might do some stuff about spam filtering but I really don’t understand much the tool to know if it does work :confused: I strongly suspect our configuration could be improved here too