[soved by @woodrow] Matrix / Synapse : python[64603]: ModuleNotFoundError: No module named '\''attrs'\''

The thread is locked. My problem was resolved by following @woodrow 's helpful instructions

My YunoHost server

Hardware: container on Proxmox
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no, I think not

Description of my issue

My Yunohost is still on Buster / 4.x, because I can’t do without Firefox sync server and I haven’t had the time yet to migrate the single app to another server that can stay at 4.x.

I ran apt update and apt upgrade via CLI. When logging in to the webadmin, the system was up to date, but a list of apps was not.

Synapse was among the outdated, so I let Yunohost run an upgrade of the app.

  • the upgrade failed (log)
  • the upgrade was unable to roll back and restore the backup
  • I checked: Matrix/Synapse was really removed from the system
  • I ran the restore manually as yunohost backup restore synapse-pre-upgrade2
  • there was a warning about restoring to an already installed system, which I ignored (what else to do?)
  • the restore seemed ok, until restarting the service: python[64603]: ModuleNotFoundError: No module named 'attrs' (log)
  • attrs seems available:
    # pip install attrs
    Requirement already satisfied: attrs in /usr/lib/python3/dist-packages (18.2.0)
  • pip did issue a warning though, WARNING: You are using pip version 21.3.1; however, version 22.3.1 is available.
  • after upgrading pip, I was still unable to restore Synapse: it still quits on attrs.

My first suspect is the apt upgrade I did just before the upgrade of Synapse: maybe a bit of Python got changed.

Any idea / suggestion where to go from here?


Take a look at error while updating from 1.67.0~ynh1 to 1.69.0~ynh1 · Issue #349 · YunoHost-Apps/synapse_ynh · GitHub, that helped me!

Thanks for the tip!

My backup also does not have attrs in the Python3.9-path of the archive, but it is available in the Python3.7-path.

My pip runs on Python3.7, python itself still points to 2.7 (yezz…)

Trying to delete the corresponding 3.7 path from the archive,

tar -dvf synapse-pre-upgrade2.tar apps/synapse/backup/opt/yunohost/matrix-synapse/lib/python3.7/site-packages/attrs-20.3.0.dist-info/`

, gives a page of warnings that the file or directory does not exist,

tar: apps/synapse/backup/opt/yunohost/matrix-synapse/lib/python3.7/site-packages/attrs-20.3.0.dist-info: Warning: Cannot stat: No such file or directory
tar: apps/synapse/backup/opt/yunohost/matrix-synapse/lib/python3.7/site-packages/attrs-20.3.0.dist-info/AUTHORS.rst: Warning: Cannot stat: No such file or directory

while testing the archive it actually is shown:

# tar -tvf synapse-pre-upgrade2.tar |grep apps/synapse/backup/opt/yunohost/matrix-synapse/lib/python3.7/site-packages/attrs-20.3.0.dist-info/
drwxr-xr-x matrix-synapse/root       0 2021-01-28 13:09 apps/synapse/backup/opt/yunohost/matrix-synapse/lib/python3.7/site-packages/attrs-20.3.0.dist-info/
-rw-r--r-- matrix-synapse/root     752 2021-01-28 13:08 apps/synapse/backup/opt/yunohost/matrix-synapse/lib/python3.7/site-packages/attrs-20.3.0.dist-info/AUTHORS.rst

The same goes for the whole python3.7 directory path.

What did you do to resolve the problem?

Nothing else than what was said on github. Sorry that doesn’t work for you.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.