[SOLVED] YUNH borks on install of Archivist "Unknown local backup archive named '20200321-195655'"

Hello!

I looked for other examples but could not find them

My YunoHost server

Hardware: : PEPPER JOBS GLK-UC2X

YunoHost version:

"packages": {
    "yunohost": {
        "repo": "stable",
        "version": "3.6.5.3"
    },
    "yunohost-admin": {
        "repo": "stable",
        "version": "3.6.5.1"

I have access to my server : all of these: Through SSH | through the webadmin | direct access via keyboard / screen | …

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? :

If yes, please explain:
no, except following the guide here on HTTPS on this website (I cant post links) http://wayneoutthere.com/how-to-yunohost-own-domain-cloudflare/

Description of my issue

I tried to install the archivist application. The official one. I clicked install, then clicked okay. Then it errored out and kicked me off the server and I had to re-login. Repeating this does the same thing.

Here’s the weird message: the weird message is at (can’t link) https://paste.yunohost.org/eyanusamal.md

Here’s the log and debug": https://paste.yunohost.org/rokexetuxu.bash

I also get The yaml metadata file associated with logs is corrupted: '/var/log/yunohost/categories/operation/20200325-222138-app_install-archivist.yml

well someone edited my post and turned things into links, so now I can’t edit it. But I wanted to say that I can install other apps just fine& thank you to anyone for their insights :slight_smile:

Unfortunately the log you provided is the remove part of the log, so without the error.
And your install log does not contains the error either, it cut short before it.

But I see a ynh_print_OFF just before the crash, or not long before (hard to say without a complete log), so my question is, did you use special characters in your password ?
If so, which special characters ?

PS: I edited your post, and now you should be able to post links.
Sorry, but we have too many spammers…

I do not have any special characters. which log would you need?

i also do have


The yaml metadata file associated with logs is corrupted: '/var/log/yunohost/categories/operation/20200325-223357-app_install-archivist.yml
Error: Corrupted yaml read from /var/log/yunohost/categories/operation/20200325-223357-app_install-archivist.yml (reason: expected '', but found ''
in "", line 1, column 13:
'**********'a'**********'r'**********'g'**** ...
^)'

The yaml metadata file associated with logs is corrupted: '/var/log/yunohost/categories/operation/20200325-223357-app_install-archivist.yml
Error: Corrupted yaml read from /var/log/yunohost/categories/operation/20200325-223357-app_install-archivist.yml (reason: expected '', but found ''
in "", line 1, column 13:
'**********'a'**********'r'**********'g'**** ...
^)'

The operation 'Install 'archivist' application' has failed! To get help, please provide the full log of this operation by clicking here

The SSOwat configuration has been generated

/etc/cron.d/archivist wasn't deleted because it doesn't exist.

Removing logrotate configuration...
Removing app main directory...
e[93me[1m[WARN]e[0m Avoid deleting .

E: Unable to locate package archivist-ynh-deps

Removing dependencies...
Loading installation settings...
The operation 'Install 'archivist' application' has failed! To get help, please provide the full log of this operation by clicking here

Validating installation parameters...
!!

archivist's script has encountered an error. Its execution was cancelled.

e[91me[1m[ERR]e[0m !!

encryption_pwd can't be empty if you choose to enable encryption.

Installing application archivist…

hmmmm I restarted and added in a different password on the encryption and that ssems to have solved it!

All those * in your logs are really strange, never seen that before.
Not even a back slash in your password? Special characters could create a big mess, or so we expect, since password aren’t into logs (hopefully).

So you reinstalled with another password and a reboot and did work this time?

nothing! just lowercase letters and numbers! maybe I didn’t fill anything in the password and happened to hit enter?

Maybe it was just a random bug of the computer, sometimes, for unknown reason computers work.

I’m currently rebooting a VPS for the same reason, suddenly it returned to its normal behavior, not working…