[SOLVED]YNH_mautrix_whatsapp - invalid macaroon

My YunoHost server

Hardware: Local computer with Proxmox, YNH is in a container.

YunoHost version: 4
I have access to my server : Through SSH, through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes, Proxmox re-initiates some files on reboot (/etc/resolve.conf, for example)

Description of my issue

I have been trying to get Mautrix_whatsapp running. It’s hard for my teenagers without Whatsapp :frowning:

I get stuck every time at connecting the bridge to matrix-synapse: invalid macaroon passed.

There is a package, ynh_mautrix_whatsapp, that helps setting up the bridge. I am crossposting here, because my first question was in the packaging-forum instead of support.

I had a warning while installing:

Ok, the warning: “go is not found” is a giveaway, of course.

I am not sure whether the package is supposed to pull in a recent version of go, so I got a recent version from the go-website and added the path as described. ‘go version’ gives 1.15, new enough to compile and run mautrix-whatsapp.

The service is now installed. The user is available (I can invite @whatsappbot:domain.tld).

Nothing happens though :frowning:

The log at /var/log/mautrix_whatsapp/log.log tells me an invalid macaroon is passed. That is the same problem I got when installing the bridge by hand. It might have to do with as_token and hs_token; they are the same in config.yaml and in registration.yaml, but I don’t know where to find them in homeserver.yaml.

I am quite sure I misunderstood some of the options during the installation or in the configuration.

Would the defaults work, or can I mess up enough there to have the install fail? I don’t understand the question ‘choose the matrix users authorized to bridge with the bot (default: admin)’. Is admin a matrix user? And the question before that, main account: should that be the YNH-user (‘username’) or the matrix user (’@username:domain.tld’)?

I have been trying to get this to work since before the start of this school year, I’m out of inspiration. Any way to troubleshoot where to look next?

Thanks in advance!

Gauthier67 chimed in in the other thread, and helped me out:

After that it came up immediately! I’ve been pushing buttons on my own for weeks, and now Yunohosts comes to the rescue again :wink: