[Solved with 4.0.7 update] Accès interface utilisateur CMS

,

Bonsoir, c’est un problème qui semble récurrent, mais non résolu pour le moment. Lorsque j’installe un système de site web/blog (j’ai essayé : Grav, SPIP, Wordpress, Pluxml) je n’arrive pas à me connecter à mon interface utilisateur, sauf avec pluxml qui ne me pose pas de souci.
J’ai des pages 404 error lorsque je tente d’accéder à l’interface : nomdedomaine.tld/yunohost/sso.
Sauf pour pluxml encore une fois.
Ces blogs sont installés sur nomdemaine.tld.
Mes autres services fonctionnent sans souci (sur des sous-domaines).

Je n’ai pas vu de solution sur le forum. Comment faire pour résoudre ça ?

J’avais essayé de mettre le nom de domaine par défaut sur un sous domaine qui pointait vers l’interface utilisateur, mais cela posait alors des problèmes pour mes mails. Par exemple : iu.nomdedomaine.tld. Mais ça me permettait d’avoir accès au blog avec nomdedomaine.tld.

Il faudrait héberger sur 2 serveurs différents le blog et le reste des services ?

Bizarre.

Personnellement j’installe mes sites sur /fr à chaque fois de façon à me laisser la possibilité d’installer une app à côté sur le même domaine. Du coup, j’utilise l’app redirect.

Je viens de faire un essai, et je reproduis le bug avec grav. (en version yunohost 4.0.4, et 4.0.3 pour ssowat).

Je regarde ce qu’il se passe

J’ai trouvé un workaround, mais j’ai l’impression que je n’ai pas encore compris l’origine exact du bug.

@ljf : d’après @kayou sur le chat :

this part: https://github.com/YunoHost-Apps/grav_ynh/blob/ab478e553843dc265bc1cfbd13d39838c2501afb/conf/nginx.conf#L6-L9 rewrite url, including /yunohost/sso

(though I’m a bit surprised because I would think ssowat acts before that rule is applied, but maybe not in the fact of simple rewrites like this)

That kind of makes sense to what I saw when you were attempting to debug it (specifically that the 404 error page URL contains something like ?q=/yunohost/sso)

I was thinking that too… But i come to the same conclusion in my side. I am checking if it’s not a change in nginx new version…

I have try to replace ngx.var.uri by ngx.var.request_uri but i got a new issue ><

Regarding this problem on grav, I had created an issue: https://github.com/YunoHost-Apps/grav_ynh/issues/41

I get the same problem with Wordpress installed on : nomdedomaine.tld, and I can’t access to roundcube which is installed on roundcube.nomdedomaine.tld. It forces me to go through the sso login page, but, because of Wordpress I go to a ‘page not found’ page on the wordpress website with this url : https://nomdedomaine.tld/yunohost/sso/?r=aHR0cHM6Ly9tYWlsLmxhdGVsaWVyZW5zYW50ZS5mci8=
The same goes for dokuwiki on dokuwiki.nomdedomaine.tld which has a restricted access.
It’s a recurrent problem. I don’t exactly know what kind of information could help you ?
And, for example, the only way to access to the yunohost-api admin webpage I must enter the IP adress of the server, and then I can go to the admin webpage.

We pretty much found a fix yesterday and should be able to release it soon™. No app reinstallation should be needed.

2 Likes

amazing ! I’ll wait for the release before setting the subject as solved ?

1 Like

(version 4.0.7 which just got released should fix the issue, assuming you did not edit your nginx conf manually)

2 Likes

Seems to be working on my tests, thanks!

1 Like

Same here, thank you !!

It works fine with me. Thank’s a lot !

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.