[Solved] Wallabag V2 installation problem


Hi, I’m trying to install wallabag V2 but it doesn’t work, here is the log from the admin panel:
`wallabag2 n’a pas été supprimé correctement
/usr/share/yunohost/helpers.d/mysql: line 62: 1: unbound variable
Removing database

  • ynh_mysql_drop_db
  • echo 'Removing database ’
  • mysqlshow -u root -pfa2fO5o2E3
  • grep -q '^| ’
  • local mysql_root_password=fa2fO5o2E3
    ++ sudo cat /etc/yunohost/mysql
  • local db_name=
  • local db_user=wallabag2
  • ynh_mysql_remove_db wallabag2 ''
    E: Unable to locate package wallabag2-ynh-deps
  • sudo apt-get -y -qq autoremove wallabag2-ynh-deps
  • DEBIAN_FRONTEND=noninteractive
  • ynh_apt autoremove wallabag2-ynh-deps
  • ynh_package_autoremove wallabag2-ynh-deps
  • dep_app=wallabag2
  • ynh_remove_app_dependencies
  • domain=my domaine name
    ++ sudo yunohost app setting wallabag2 domain --output-as plain --quiet`

I previously installed wallabag(V1), I deleted it and then I tried to install wallabag V2. Maybe it’s the main problem?
I guess I should manage the mysql database, but I don’t know how, and furthemore I don’t know if it would be a clean way to do.

I don’t know if I have to talk about this kind of issue on GIthub, or the yunohost forum?

Hello @Kapu06 :slight_smile:

Could you please run the installation from command-line, with yunohost app install https://github.com/YunoHost-Apps/wallabag2_ynh --verbose (the verbose option is important to get the full log)
Then you can copy it here or upload it somewhere (like: https://paste.yunohost.org/)
And first run yunohost app list -i | greb wallabag (the result should be blank if wallabag is not installed)

For my part, it doesn’t really matter, you opened this topic so let’s use it :wink:
In theory it’s better to open an issue on github to keep track of all the bug reports, but the issue is related to a misconfiguration/bug of your Yunohost instance (so not linked to wallabag app) help from other people here can be useful.

Ok, thank you @Lapineige =)

Here is my –verbose.

It seems to be a problem with ascii? O_o

Sorry, I wrote greb instead of grep :sweat_smile:.

I’ve seen this issue in the past (probably the solution is in this topic: Wallabag v2 - intégration dans yunohost?).
It was perfectly working on my side, and another try solved the issue, if I remember well.
Not an ascii error, but a wrong manifest file or something like this. The line “version” doesn’t have the right content.

Here is the interesting log

For the record, a solution to an analog problem has been described here

Hey, I tried it with the fr language (export LANG=fr_FR.UTF-8), but a strange thing happened:

dpkg-reconfigure locales -bash: dpkg-reconfigure: command not found

I tried to install dpkg or debconf but it seems to be already installed. So I don’t get why I have this problem =/

Edit: I also noticed this in the debug consol of yunohost:
E: Unable to locate package wallabag2-ynh-deps Maybe interesting?

You need to be root or use sudo to reach dpkg-reconfigure (e.g. sudo /usr/sbin/dpkg-reconfigure).
The E: Unable to locate package wallabag2-ynh-deps is perfectly normal in your case, as the installation fails, yunohost tries to remove the package, and the dependencies hadn’t had time to get installed.

1 Like

Thanks ^^ I thought I did it in sudo but apparently not, I just did again following your advises and it worked! =)

Thanks @JimboJoe and @Lapineige =)

1 Like

Happy you got it sorted out!

I remember now, I had this issue before, and indeed it was an issue with the locales.

Good to know, thanks :slight_smile: