[SOLVED] Vaultwarden invalid admin token

Hardware: VPS bought online ( Contabo )
YunoHost version: (stable)
I have access to my server : Through SSH and browser
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

i install vaultwarden.
i receive the admin token.
i insert the admin token in the admin page.
i receive Error: Invalid admin token, please try again..

i’ve tried already to uninstall and reinstall, but it keeps happening.

I think people will want to see the log of your install to see what is happening.

are we talking about the install of vaultwarden, right?
just asking because i didn’t understand why you quoted the vps line.

anyway,s in the logs in service i can only find this much.

should i reinstall it or there is a way to get more info somehow?

You tried to see in :arrow_heading_down:

nano /var/www/vaultwarden/live/.env


nano /home/yunohost.app/vaultwarden/config.json

1 Like

with cat /var/www/vaultwarden/live/.env i get this.

while with cat /home/yunohost.app/vaultwarden/config.json i get this.

with the first command i noticed the possibility to disable the token. should i go for that? even if it doesn’t seem safe anyway. :upside_down_face:

No, don’t disable anything, but one of the 2 keys must be correct.

Otherwise there is another possibility
nano /etc/yunohost/apps/vaultwarden/settings.yml (if it exists of course).

You should find the correct admin token, write them down and try to see which is the correct admin token.

didnt realise there were two different keys.

one of the two worked (the one that wasn’t sent to my email).

thank you for the help.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.