[Solved] Synapse fails to restore on a fresh installation

My YunoHost server

Hardware: Raspberry 3B
YunoHost version: 11.2.5
Synapse version: 1.94
I have access to my server : Through SSH and/or through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : Yes
If yes, please explain: I try to restore my Yunohost instance to a new SD Card with a 64 bits OS (currently installed on a 32 bits one)

Description of my issue

Hello everyone, I try to restore my Yunohost instance to a new SD Card with a 64 bits OS (currently installed on a 32 bits one) The restoration of Yunohost itself went well and I am able to log to the web admin, access through SSH and everything but I am stuck with Synapse. I solved some errors but there is still some and the script fails to restore in the end.

The 3 warnings I have in the logs are:

2023-10-21 16:28:45,946: WARNING - setfacl: Option -m: Invalid argument near character 3
2023-10-21 16:28:45,949: WARNING - setfacl: Option -m: Invalid argument near character 5

But I think the one that cause the script to fail is:

2023-10-21 16:44:30,463: DEBUG - + pip3 install --upgrade setuptools wheel pip
2023-10-21 16:44:30,465: WARNING - ../settings/scripts/_common.sh: /opt/yunohost/matrix-synapse/bin/pip3: /opt/yunohost/matrix-synapse/bin/python3: bad interpreter: No such file or directory

Here is the full log: https://paste.yunohost.org/raw/ofojaduqah

I saw the suggestion of @wbk on this post: Synapse update fails, impossible to restore - #20 by wbk and I looked for to edit the _common.sh like suggested but from what I saw, the change is already done in the last version of Synapse (1.94).

I am a bit out of idea, so thanks in advance for any suggestion that could help me restore my Synapse instance.

Hi Lanky,

How unfortunate your Synapse does not restore!

I have previously migrated from 32bit to 64bit, actually from ArmHF (on Orange Pi Zero) to Intel x64 (on Proxmox). I started with plain Debian, and added Yunohost and after that the backups. The backups restored with no problem. Even though that was more than a year ago, I am quite sure your problem does not have its cause in the migration.

It is exactly the same place as where @Totu has his error, and where I had it. @TheTrveAnthony had a backup of a much older Synapse, in his case the setuptools-switch seemed to have worked in this location (but he still had a metadata-error later on).

Is your old host still running/available? You might try upgrading Synapse to the latest version (your log states YNH_APP_MANIFEST_VERSION: 1.91.2~ynh1, I have 1.92.3~ynh1 installed). Probably won’t fix it, but worth a try.

I am not knowledgeable enough about Python/PIP to have an idea why this problem keeps popping up :frowning:

Hi wbk,

Thank you for your reply, yes for now I putted back my old SD card in the Raspberry and Synapse is still working on it. But I think you might have mixed my logs with those of Totu, because I have Synapse 1.94.0~ynh1 :wink:

Hopefully someone will have an idea

Update : I seem to have finaly managed to restore it successfully!

I did 2 changes since the last try so I am not sure about which solved it.
The 2 modifications are:

  1. I stumbled upon this issue on the Synapse-ynh repository and more specifically this reply from Josue-T who is the maintainer, that say that the architecture change needs a modification in the restoration script. I made the change in my backup.

  2. I didn’t specified it earlier but my backup was on an external HDD binded to the backup folder of Yunohost. This time I canceled the bind mount and moved the backup archive to the card.

1 Like

Great that you got it solved, thanks for posting!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.