[SOLVED] Roundcube carddav acces to baikal addressbook

Hello all,

I have installed with succes yunohost on a jessie host.

I have installed Baikal then roundcube. Everything is working well except acces to the address book via carddav.

I tried several times to remove/install baikal an roundcube without any success.

I’am thinking about an authentication failure.

In /var/log/nginx/-access.log I can see the messages below (when trying to add contact via roundcube) : - - [02/Aug/2015:12:51:05 +0200] "GET /baikal/card.php/addressbooks/<username>/default/809C040A-272E-4A2E-A6F3-D65B6B023CBA.vcf HTTP/1.1" 401 304 "-" "RCM CardDAV plugin/1.0.0" - - [02/Aug/2015:12:51:05 +0200] "PUT /baikal/card.php/addressbooks/<username>/default/809C040A-272E-4A2E-A6F3-D65B6B023CBA.vcf HTTP/1.1" 401 304 "-" "RCM CardDAV plugin/1.0.0"

GET and PUT were failed with an 401 return code.

I tried to acces to my addressbook using a cli tools “syncevolution”.

The command line result is :

$ syncevolution --print-databases backend=carddav username=<username> "password=<my_password>" SSLVerifyServer=0 syncURL=https://klood.horria.fr/baikal/card.php/addressbooks/<username>/
[INFO] start database search at https://<my_domain>/baikal/card.php/addressbooks/<username>/, from sync config '@default', syncURL='https://<my_domain>/baikal/card.php/addressbooks/<username>/'
   Default Address Book (https://<my_domain>:443/baikal/card.php/addressbooks/<username>/default/) <default>
   pro (https://<my_domain>:443/baikal/card.php/addressbooks/<username>/pro/)
$ echo $?

Adressbook are listed and command returne code is 0

In /var/log/nginx/-access.log I can read : - <username> [02/Aug/2015:13:20:11 +0200] "PROPFIND /baikal/card.php/addressbooks/<username>/ HTTP/1.1" 207 1440 "-" "SyncEvolution" - <username>[02/Aug/2015:13:20:11 +0200] "PROPFIND /baikal/card.php/principals/<username>/ HTTP/1.1" 207 1313 "-" "SyncEvolution" - <username> [02/Aug/2015:13:20:11 +0200] "PROPFIND /baikal/card.php/addressbooks/<username>/ HTTP/1.1" 207 1440 "-" "SyncEvolution" - - [02/Aug/2015:13:20:11 +0200] "PROPFIND /baikal/card.php/addressbooks/<username>/ HTTP/1.1" 401 304 "-" "SyncEvolution" - <username> [02/Aug/2015:13:20:11 +0200] "PROPFIND /baikal/card.php/addressbooks/<username>/ HTTP/1.1" 207 1840 "-" "SyncEvolution" - <username> [02/Aug/2015:13:20:11 +0200] "PROPFIND /baikal/card.php/addressbooks/<username>/default/ HTTP/1.1" 207 1708 "-" "SyncEvolution" - <username> [02/Aug/2015:13:20:11 +0200] "PROPFIND /baikal/card.php/addressbooks/<username>/pro/ HTTP/1.1" 207 1652 "-" "SyncEvolution"

This time I faced one 401 (one a request I do not understand, maybe specific to syncevolution) but 207 when listing adressbook.

To be sure I send a wrong password with syncevolution command and :

In /var/log/nginx/-access.log : - <username> [02/Aug/2015:13:26:30 +0200] "PROPFIND /baikal/card.php/addressbooks/<username>/ HTTP/1.1" 401 297 "-" "SyncEvolution" - <username> [02/Aug/2015:13:26:30 +0200] "PROPFIND /baikal/card.php/addressbooks/<username>/ HTTP/1.1" 401 297 "-" "SyncEvolution"

On my screen :

$ syncevolution --print-databases backend=carddav username=<username> "password=<wrong_password>" SSLVerifyServer=0 syncURL=https://<my_domain>/baikal/card.php/addressbooks/<username>/
[INFO] start database search at https://Vbaikal/card.php/addressbooks/<username>/, from sync config '@default', syncURL='https://Vr/baikal/card.php/addressbooks/<username>/'
[ERROR] PROPFIND: Neon error code 3 = NE_AUTH, HTTP status 401: Could not authenticate to server: rejected Basic challenge
$ echo $?

Any idea of what is happening ?

Thanks by advance



Sorry for the tag [SOLVED] because this topic is not really solved.

I do not know why but it seems that the root cause is my installation :

  • From an another yunohost instance, I can connect roundcube to my address book
  • From a client device (android) or from a client software (evolution) I can connect to my address book and calendar

About the http code 401, it seems it is normal (https://github.com/netgusto/Baikal/issues/68)

My knowledge about the yunohost code is too light to understand what happened so I will reinstall my server.

Sorry for the noise.




I have found why from roundcube I can not access to the baikal’s addressbooks.

After I reinstalled my server and yunohost, I had the same error. I can access to addressbook from an external device or software. So I thought that the only difference between roundcube and others devices/softwares is connection source (outside vs inside).

My server name (server.domain.tld) was in the /etc/hosts file in front of the IP
I deleted the canonical name from this file and now everything’s work fine.

I guess I have a lack in dns management/configuration and in yunohost app management, so if someone had an explanation of what happened to me, I’am listenning.