[SOLVED/RESOLU] Ou trouver les images amd64 stretch? Where to find the amd64 Stretch images?


Mon serveur YunoHost

Matériel: Raspberry Pi 3/Gandi Cloud amd64
Version de YunoHost: YunoHost (stable).
J’ai accès à mon serveur: En SSH **
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Bonjour a tous et merci a nouveau pour cette tres belle brique de l’Internet qu’est YHN !

Je suis actuellement sur la version stretch auto-heberge sur mon Raspberry Pi 3 et je demenage. Je deplace donc mon serveur vers une instance cloud (Gandi) et je pensais pour cela installer YNH Stretch et recuperer ma sauvegarde en post-install (avant de pouvoir terminer ma migration et passer sur Buster R-Pi 4).

Le probleme est que les liens vers les images Stretch amd64 finissent tous en 404, par exemple https://build2.yunohost.org/1-yunohost-stretch-latest-amd64-stable.iso. J’ai aussi essaye sur build.yunohost.org avec le meme resultat.

Quelqu’un saurait-il ou les trouver? Un grand merci a vous tous !

PS: il y avait un fil a ce sujet pour les images R-Pi sur Old Raspberry images not available any more mais il a fini ferme apparemment sans reponse …


My Yunohost server

Hardware: Raspberry Pi 3/Gandi Cloud amd64
YunoHost version: YunoHost (stable).
I access my server: En SSH
Particular context or mods ? : no

Problem description

Hello everyone and thanks much for this wonderful piece of the Internet that is YNH !

I am currently self-hosted on an R-Pi 3 and I am moving. I am thus relocating my server to a Gandi cloud instance. I figured I would install the Stretch version of YNH and pick up my save via postinstall (before eventually moving to Buster on R-Pi 4).

The issue is that links to Stretch images for amd64 all end up in 404, for instance https://build2.yunohost.org/1-yunohost-stretch-latest-amd64-stable.iso. I also tried build.yunohost.org with the same result

Would sb happen to know where they are? Thank you very much !

PS: there was a thread about this topic on R-Pi at Old Raspberry images not available any more but it apparently closed w/o an answer …

Hi there,

Just a note to mention that if there is an automated way (e.g the YNH CI/CD scripts) to rebuild the Stretch image, this would work for me too!

Edit: @Aleks would you happen to know here (or have a pointer to the person who does)? Many thanks!

I think the easiest way is in fact just to setup a Debian Stretch VPS on your Gandi cloud thingy, and just curl https://install.yunohost.org/stretch | bash

Fantastic! Indeed this should work, I’ll proceed with that and report back with the results.

Thank you very much @Aleks!

Hi again,

Here is a final note as I completed the move of my YNH R-Pi3 onto the Gandi Cloud.

Everything worked superbly, I made a final backup locall on my Raspberry Pi, transferred it to my VPS and, after installing Stretch + Yunohost as @Aleks had advised, I proceeded to restore my backup via yunohost backup restore XXX instead of the postinstall step.

I had only two apps (Dokuwiki and Nextcloud). Dokuwiki failed to be restored because php7.3-fpm was not being available seemingly but it then got installed/reinstalled when Nextcloud was restored. I then reran the backup restore step, this time only for Dokuwiki and it then succeeded.

That ability to restore a full server from backups as part of postinstall is really a fantastic feature! Thank you very much YNH team for it and for the great stack that is YNH !

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.