[Solved] Nextcloud's Gestion app is not working

:uk:/:us: Message template (english)

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 11.2.4
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: Nextcloud 27.0.2~ynh1

Description of my issue

I’m trying to use the Gestion app in Nextcloud, https://apps.nextcloud.com/apps/gestion, without success.
It doesn’t display as it should (I have tried this app on an other nextcloud not based on Yunohost) and I get plenty of error in the firefox console :

  • 405
  • Uncaught ReferenceError: showError is not defined
  • Source map errors

Does anyone manage to install Gestion in Nextcloud?

I opened an issue on github to talk about it Sadly, nothing works.. [object Object] error · Issue #360 · baimard/gestion · GitHub

I tried on a fresh install of Yunohost and Nextcloud.

I think it is linked to nginx reverse proxy but I don’t know what test I could make to find the solution. I’m afraid that if I face this issue with this nextcloud app, it might happen for others.

After reading these two pages :

it looks like PROPFIND and PROPPATCH , which are two methods used with WebDAV, and they are used to query or set properties for a URI, are not yet handle by yunohost nextcloud nginx conf.

Any idea what I should do to try to make it working?

The solution was given by tituspijean. Thanks to him.

Edit /etc/nginx/conf.d/<nextcloud domain>.d/nextcloud.conf to have on line 138 if ($request_method ~ ^(PUT|DELETE|PATCH|PROPFIND|PROPPATCH)$) {

and it works.

I’ll report to nextcloud’s yunohost app.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.