[Solved] Nextcloud update from 25.0.3 is broken, Nexcloud is gone

My YunoHost server

Hardware: PC 64 Bit
YunoHost version: 11.2.3 (fresh uipgrade)
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes;
I had installed samba for my LAN; had reverted the text “bullseye” to “stable” in sources.list for new packets.
Since ynh complained about that, I reverted that, and Yunohost could successfully update to 11.2.3.
But: samba was deleted and I suppose some conf files were lost/changed (nginx?).

If your request is related to an app, specify its name and version: nextcloud 22.2.7~ynh1 to 25.0.3~ynh1
Tried to update Nextcloud (old version 25.0.3), but didn’t succeed.
After that, cannot access Nexcloud web page, it is showing the nginx default page " Welcome to nginx!".
As Nextcloud is in a subdomain, the main YNH domain is working.

Pastbin: https://paste.yunohost.org/raw/anocecikim
Interesting lines:

2023-08-18 18:37:35,155: DEBUG - Updating database schema
2023-08-18 18:37:37,001: DEBUG - Exception: Database error when running migration 13000Date20170718121200 for app core
2023-08-18 18:37:37,001: DEBUG - The column ‘scope’ on table ‘oc_authtoken’ already exists.
2023-08-18 18:37:37,001: DEBUG - Update failed

I have a full backup of db and data.
Is it possible to remove nextcloud completely and reinstall it (and connect it to ‘old’ db & data)?
Which nextcloud version can I take?
I didnt find the same old ynh nextcloud-app version 25.0.3. How is it possible to reinstall that?
Or is it possible to install the new version 27.2.7 und connect that to my ‘old’ db?

Thanks for any help!

Hi there,
I am a step further.
Now, nginx is showing me an error message:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

But - I cannot find any error message (except the above) on my server (var/log/*, .
Where can I look else?

Hi there,
i have solved it myself.
The inner problem was an app in nextcloud, that could not be upgraded, and ynh could not do it itself.
Then, there was much confusion about the right version of php (the php hell!), since nextcloud 25 claimed to need >= php8.0, but that was not true.
I changed the nginx php requirement for nextcloud25 to php7.4, restored a backup of my nextcloud db, removed the failed old app of nextcloud, and so ynh could upgrade itself to 27.0.2.

After a reboot nextcloud is up again :slight_smile:


Thanks ! Thinking of updating here. Would you mind telling me which app it was?

It was an old joplin app (not avail any more).
I killed it via occ apps:remove.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.