[SOLVED] Nextcloud fails to update

Hardware: VPS bought online ( Contabo )
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoH

i was just trying to update my nextcloud app, specifically from v27.1.4 to v28.0.1 and it crashed with an error.

i run this command
yunohost app upgrade nextcloud --force
following this advice, but it didn’t work. same error.

now, when i navigate to my nextcloud page, i’ welcome by a blank page with this error

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

here you can find the logs for the failed update.

this isn’t my main cloud, which now i’m scared to update even though in that case the update would be from 28.0.1~ynh1 to 28.0.1~ynh2. should that be effortless?


Error: App “Breeze Dark” cannot be installed because the following dependencies are not fulfilled: Server version 27 or lower is required.

Breeze dark is incompatible with NextCloud 28, please disable it before upgrade, as asked in the pre-upgrade message

i cannot access my nextcloud anymore as i said in the op.

also, i don’t remember if the message was popping up yesterday, when i originally tried to update, that’s why i didn’t check.

if it did, i completely missed.

can you try the following command please?

sudo -u nextcloud php8.2 --define apc.enable_cli=1 /var/www/nextcloud/occ app:disable breezedark

i tried with both the admin account and the main user with admin privileges and that’s the error message i receive:

Sorry, user admin is not allowed to execute '/usr/bin/php8.2 --define apc.enable_cli=1 /var/www/nextcloud/occ app:disable breezedark' as nextcloud on domain.ltd.

and if i try with root, i receive
No such app enabled: breezedark

Then you already disabled breezedark at some point

why would i be getting that error then: :cry:

I mean maybe you did disable breezedark during all your attempts at disabling it, and you should re-try the upgrade

sorry, i get what you mean now. :sweat_smile:

however, i tried again and got the same error. tried both in the webadmin and ssh.

i thought of switching it app and running

sudo -u nextcloud php8.2 --define apc.enable_cli=1 /var/www/nextcloud/occ app:enable breezedark

as root and that’s the message i received:

App "Breeze Dark" cannot be installed because it is not compatible with this version of the server.

does it mean my app believes it is already updated to version 28.1 for some reason? :upside_down_face:

I don’t know how / why it would try to update the app if it’s not installed …

Can you run the following and confirm that it doesn’t return anything …?

cd /var/www/nextcloud
sudo -u nextcloud php8.2 --define apc.enable_cli=1 occ --no-interaction --no-ansi app:list | grep dark

it actually returns this

- breezedark: 26.0.0 (installed 26.0.0)

Hmm my bad, i think there are “enabled” apps and “disabled” apps so let’s display the full list with

cd /var/www/nextcloud
sudo -u nextcloud php8.2 --define apc.enable_cli=1 occ --no-interaction --no-ansi app:list

Is it listed in the enabled apps, or the disabled apps ?

it’s in the disabled apps:

  - activity: 2.19.0
  - calendar: 4.5.3
  - circles: 27.0.1
  - cloud_federation_api: 1.10.0
  - comments: 1.17.0
  - contactsinteraction: 1.8.0
  - dashboard: 7.7.0
  - dav: 1.27.0
  - federatedfilesharing: 1.17.0
  - federation: 1.17.0
  - files: 1.22.0
  - files_external: 1.19.0
  - files_pdfviewer: 2.8.0
  - files_reminders: 1.0.0
  - files_rightclick: 1.6.0
  - files_sharing: 1.19.0
  - files_trashbin: 1.17.0
  - files_versions: 1.20.0
  - fileslibreofficeedit: 1.1.0
  - firstrunwizard: 2.16.0
  - logreader: 2.12.0
  - lookup_server_connector: 1.15.0
  - nextcloud_announcements: 1.16.0
  - notifications: 2.15.0
  - oauth2: 1.15.1
  - onlyoffice: 8.2.4
  - password_policy: 1.17.0
  - photos: 2.3.0
  - privacy: 1.11.0
  - provisioning_api: 1.17.0
  - recommendations: 1.6.0
  - related_resources: 1.2.0
  - serverinfo: 1.17.0
  - settings: 1.9.0
  - sharebymail: 1.17.0
  - support: 1.10.0
  - survey_client: 1.15.0
  - systemtags: 1.17.0
  - text: 3.8.0
  - theming: 2.2.0
  - twofactor_backupcodes: 1.16.0
  - user_ldap: 1.17.0
  - user_status: 1.7.0
  - viewer: 2.1.0
  - weather_status: 1.7.0
  - workflowengine: 2.9.0
  - admin_audit: 1.17.0
  - breezedark: 26.0.0 (installed 26.0.0)
  - bruteforcesettings: 2.7.0
  - encryption: 2.15.0
  - suspicious_login: 5.0.0
  - twofactor_totp: 9.0.0
  - updatenotification: 1.17.0 (installed 1.15.0)

Well that’s totally confusing, that goes beyond what I know about Nextcloud …

My guess is that when we tell it to “update” the apps, it want to update even apps that are not even enabled … Isn’t there anything in your Nextcloud admin interface to really uninstall the app, not just disable it ?

the web nextcloud admin interface is not accessible :grimacing:

1 Like


:smiling_face_with_tear: :smiling_face_with_tear: :smiling_face_with_tear:

Maybe it helps to uninstall the app (app:remove instead of app:disable)?

sudo -u nextcloud php8.2 --define apc.enable_cli=1 /var/www/nextcloud/occ app:remove breezedark

Yes, it worked! Thank you very much for your help!!! :partying_face:

1 Like