[SOLVED] Mail : Amavis FAILED: Unix utility file(1) not available

Hi all !

Since yesterday evening I can’t send or receive any mail correctly.

Because of Amavis…

Amavis keeps complaining because it can’t find file(1) utility. I looked around on other forums and found these answers :

  1. file is not in the path.
  2. amavis is chrooted and can’t access file(1) in its jail.

I don’t know which user launches amavis (root? the mail sender? any system related user? any yunohost user?) so I can’t tell the value of $PATH

file seems to be accessible in /usr/bin as most of programs :

whereis file
file: /usr/bin/file /usr/share/file /usr/share/man/man1/file.1.gz

Here is my mail.err log => https://microcheap.info/zerobin/?7a45c44c31be7785#AVLWH6P+c6WsGca8p9eUMZOjP2E9+4avxuFdZKqjiAA=

And mail.info => https://microcheap.info/zerobin/?7349a3772627e383#bFINQNGakzYZNvcdr+td05HLoEBVT30XqxmIgXtmTsA=

I’ve tried to dpkg purge yunohost-config-amavis then reinstall it without succes.

Simply, which user uses amavis ? And then where is set its $PATH ?

work around :smile:

echo "\$file = \"/usr/bin/file\" \;" > /etc/amavis/conf.d/60-file_missig_fix
echo "1 \;" >> /etc/amavis/conf.d/60-file_missig_fix

But still to me it looks quick and dirty.

Strange behaviour indeed.

Thank you for the reporting (and the “dirty” workaround), I’ll let you know if we run into this by our side.

I really don’t know if it is related but still :

Yesterday I tried to install sudo and mistyped after a warning saying it is in conflict with almost every ynunohost related packages. So reinstalled 'em all.

This said it might be helpfull to protect sudo by including a protective rule in apt over the sudo package (and any yunohost stuff with conflicting package) in /etc/apt/preferences.

Package: sudo
Pin: release a=yunohost
Pin-Priority: 900

Or something so…

Previous fix will be overwritten on every apt -get or yunohost app action

Here is a cleaner fix

dpkg --purge --force-depends amavisd-new
apt-get install --reinstall amavisd-new

Looks like the sudo/sudo-ldap stuff removed amavisd-new default config files