[Solved] Installation: dialog n'est pas disponible / dialog is not available

Hello,
I have issue with YNH installation :slight_smile: the .iso is not working due to partition issue, and now the script is returning me an error :smiley:
Basically, i have installed debian 10.10 flawlessly, directly from iso, out of the box. I try now to install YNH with the installation script, and it seems “dialog” is now flagged as obsolete:

Aucune version du paquet dialog n’est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu’il est devenu obsolète
ou qu’il n’est disponible que sur une autre source
E: Le paquet « dialog » n’a pas de version susceptible d’être installée
[FAIL] Unable to install dependencies to install script

Is this a known issue ?

Here is my installed repos apt-cache policy:

Fichiers du paquet :
100 /var/lib/dpkg/status
release a=now
500 http://deb.debian.org/debian buster-updates/main amd64 Packages
release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=amd64
origin deb.debian.org
500 http://security.debian.org/debian-security buster/updates/non-free amd64 Packages
release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=amd64
origin security.debian.org
500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
origin security.debian.org

Thank you VM for the help, before installing dialog manually, i’d like experts advices :wink:

Solved

my debian repo was not including the buster repo (only buster-updates)
given the buster repo was provided by the DVD (well, usb key…) during install.

Adding the following entry to /etc/apt/sources.list solved the issue
deb http://deb.debian.org/debian buster main non-free contrib

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.