[SOLVED] How to setup Converse?

Hardware: VPS bought online ( Contabo )
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no


Apologies in advance for possibly creating a topic for a very silly issue, but here we are.

I’ve installed Converse and now I’m lost.
What else should I do to be able to start using it?

Links to guides and tutorials are of course well accepted.
I can’t find a lot about Converse when I research and I don’t know what of how much of what I find is applicable when using YunoHost.
Hope I’m making sense.

Many thank to whoever will be able to help.

First you need an xmpp server with an account (you already have it thanks to yunohost)
Second You need to check this file /var/www/converse/index.html
With your xmpp server
If it seems good you can login into converse with your xmpp credentials which is your yunohost credential

        authentication: 'login',
        auto_away: 300,
        auto_reconnect: true,
        bosh_service_url: 'https://chat.exemple.com//http-bind',
        default_domain: 'chat.exemple.com',
        message_archiving: 'always',
        view_mode: 'fullscreen',
        assets_path: '/dist/',
        play_sounds: true,
        sounds_path: '${assets_path}/sounds/'

What do you mean by “checking that file”?
Everything should be like the text you highlighted?

Everything should be set at install. Just connect to converse with you YunoHost username/password

Ok, so, I tried to reinstall on my main domain, and it actually worked alright. I logged in easily as you said.
However, if I try to install it on a subdomain, it doesn’t login.
I get this error:

Authentication failure

Your XMPP address and/or password is incorrect. Please try again.

1 Like

Yes I can reproduce this.
Using only the username/password to loggin doesn’t work with subdomain install.
You need to use the email/password (your XMPP address is the same as your user email)

This should be fixed on testing branch.

1 Like

might be related to cross domain problems I reported here? :thinking:

I hope this helps to solve it after review it on testing by devs. Thank you

unfortunately not the same problem. This one is du to a setting option that allow to connect only with the username instead of the full address.

1 Like

It worked as you said.

Thank you very much for the help. :blush:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.