[SOLVED] Got a message from Cron <root@XXXX> yunohost dyndns update >> /dev/null

Hi everyone!

Here is my problem:

**Hardware: APU2
https://www.pcengines.ch/apu2.htm
YunoHost version: 3.6.5.3
I have access to my server : Yes, through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I got the following message again and again:

Traceback (most recent call last):
File “/usr/bin/yunohost”, line 214, in
timeout=opts.timeout,
File “/usr/lib/python2.7/dist-packages/moulinette/init.py”, line 136, in cli
moulinette.run(args, output_as=output_as, password=password, timeout=timeout)
File “/usr/lib/python2.7/dist-packages/moulinette/interfaces/cli.py”, line 425, in run
ret = self.actionsmap.process(args, timeout=timeout)
File “/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py”, line 523, in process
return func(**arguments)
File “/usr/lib/moulinette/yunohost/log.py”, line 284, in func_wrapper
result = func(*args, **kwargs)
File “/usr/lib/moulinette/yunohost/dyndns.py”, line 235, in dyndns_update
old_ipv4 = check_output(“dig @%s +short %s” % (dyn_host, domain)).strip() or None
File “/usr/lib/python2.7/dist-packages/moulinette/utils/process.py”, line 29, in check_output
return subprocess.check_output(args, stderr=stderr, shell=shell, **kwargs)
File “/usr/lib/python2.7/subprocess.py”, line 219, in check_output
raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command 'dig @dyndns.yunohost.org +short xxxx.ynh.fr’ returned non-zero exit status 10

For information, I had a xxxx.ynh.fr domain that I changed to a personal one 2 months ago. Everything is working fine with my new domain and I deleted the old one (xxxx.ynh.fr).
But it seems pretty clear that this message is linked to this change. How could I change/clean this ?

Thanks!

Same issue on a VPS, I reinstalled my server and issue disappeared, seems that Yunohost wants to keep dynDNS updated even if the domain doesn’t exist.

Yea, sorry, that’s an old bug still not fixed, when a dyndns domain is removed, is doesn’t remove the cron job …

Running ‘yunohost dyndns removecron’ should solve the issue.

Resolved!
Many thanks,
Hervé