[SOLVED] Failed Yunohost installation

Hardware: VPS bought online ( Contabo )
YunoHost version: /A
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

i’m trying to install yunohost on a new vps, but i get this error:

curl https://install.yunohost.org | bash
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 22546  100 22546    0     0   217k      0 --:--:-- --:--:-- --:--:--  217k
[FAIL] YunoHost is only available for the version 10 (Buster) of Debian, you are using 'bullseye/sid'.
[INFO] Installation logs are available in /var/log/yunohost-installation_20220421_142133.log

what i don’t understand is that i’m already using yunohost installed on a similar vps from the same company so what’s the problem with this one? :cry:

do i have to downgrade the debian version on the server?

Yes. If you want to install the stable version of YunoHost (4.3) you need to install it on top of Debian 10 Buster.

If you want to install YunoHost on top of Debian 11 Bullseye, you have to install YunoHost 11 testing with the following command :

$ wget https://install.yunohost.org/bullseye -O install_script
$ bash install_script -d testing
1 Like

it worked, but then i decided to downgrade to 10 and use the stable version for now. :sweat_smile:

thank you very much for your help. :heart:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.