[SOLVED] Error during DNS configuration

Hardware: VPS bought online ( Contabo )
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Hello everyone.

I’m having trouble with the DNS configuration, specifically I’m unable to add the important dot at the end of mydomain.com**.** in the value section.
I keep receiving the “Must be a valid DNS name” error.
The only way I can insert it is without the dot, but I guess it won’t work then?

It is my first time using YUNOHOST and setting up a server.

So, thanks for your time and your help. :blush:

Eeeeh, maybe that’s fine, it kinda depends on on your registrar’s interface is designed … What registrar are you using ?

You mean it might be good also without the final dot?

Hmmmyeah i don’t know, maybe, it’s hard to say without seeing the interface

But wouldn’t be surprised that they automatically add it internally, because that’s something that typically confuses people

Yeah! You were right. It worked without the dot. :stuck_out_tongue:

Although, now, I don’t get the difference between @ and * in the DNS configuration.

Let’s say you’re configuring the domain called domain.tld

Then @ corresponds to domain.tld (or more precisely, in DNS notation, domain.tld., with a dot at the end, meaning it’s an “absolute domain”, which is usually implicit, but made explicit in technical configuration with that dot)

* corresponds to *.domain.tld., and is a wildcard, so basically means “every subdomain” (or more precisely - any subdomain that’s not already handle by another A record)

So, in name I have to set *.domain.ltd. while in value I have to put either my IPv4 ormy IPv6?

In name, you have to set *

All done!
The diagnosis says everything is perfect. :smiley:

Thank you very much indeed for your help.
Wish you all the best. :heart:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.