[SOLVED] Configuration is broken for service nginx

Hardware: VPS bought online ( Contabo )
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no


When run diagnosis I receive this warning:

[WARNING] Configuration is broken for service nginx!

Here you can find the logs.

Anyone can help>

Hmokay can you try to log as admin or root and share the output of : /usr/sbin/nginx -t

Just one line:

Segmentation fault

Doesn’t sound reassuring :sweat_smile:

Tried again and got a different output this time:

nginx: [emerg] dlopen() "/usr/share/nginx/modules/ngx_http_image_filter_module.so" failed (/lib/x86_64-linux-gnu/libwebp.so.6: unexpected reloc type 0x47) in /etc/nginx/modules-enabled/50-mod-http-image-filter.conf:1
nginx: configuration file /etc/nginx/nginx.conf test failed

Hmokay let’s look at the output of :

ls /usr/share/nginx/modules/


dpkg --audit

The first one give this:

ndk_http_module.so			ngx_http_lua_module.so
ngx_http_auth_pam_module.so		ngx_http_perl_module.so
ngx_http_cache_purge_module.so		ngx_http_subs_filter_module.so
ngx_http_dav_ext_module.so		ngx_http_uploadprogress_module.so
ngx_http_echo_module.so			ngx_http_upstream_fair_module.so
ngx_http_fancyindex_module.so		ngx_http_xslt_filter_module.so
ngx_http_geoip_module.so		ngx_mail_module.so
ngx_http_headers_more_filter_module.so	ngx_nchan_module.so
ngx_http_image_filter_module.so		ngx_stream_module.so

Nothing happens when I write the second one instead.

Hmokay naively let’s do a apt install libwebp6 --reinstall and see if that fixes the nginx -t message

It did fix it?

admin@mms:~$ sudo apt install libwebp6 --reinstall
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 4 not upgraded.
Need to get 0 B/261 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 70189 files and directories currently installed.)
Preparing to unpack .../libwebp6_0.6.1-2+deb10u1_amd64.deb ...
Unpacking libwebp6:amd64 (0.6.1-2+deb10u1) over (0.6.1-2+deb10u1) ...
Setting up libwebp6:amd64 (0.6.1-2+deb10u1) ...
Processing triggers for libc-bin (2.28-10) ...
Scanning processes...                                                           
Scanning candidates...                                                          
Scanning linux images...                                                        

Running kernel seems to be up-to-date.

Restarting services...
 systemctl restart movim.service nginx.service php7.3-fpm.service

No containers need to be restarted.

No user sessions are running outdated binaries.
admin@mms:~$ sudo /usr/sbin/nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

The diagnosis also says

Service nginx is running!

Hence, problem solved I guess? Thank you very much?
Will wait for your confirmation. :sweat_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.